Bug 443409 - ypbind always fails to bind at boot for me
ypbind always fails to bind at boot for me
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
9
All Linux
low Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-21 09:17 EDT by Thomas J. Baker
Modified: 2009-07-14 13:51 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 13:51:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas J. Baker 2008-04-21 09:17:41 EDT
ypbind-1.20.4-4.fc9.x86_64, up to date F9 preview/rawhide system. 

I have a single server specified by ip address, I have the firewall set to
disabled although by default, it has some iptables rules anyway (I'm
bugzilla'ing that since it makes broadcast ypbind not work), I have selinux in
permissive mode. Everytime I boot, ypbind fails to bind. I've had to add a
'service ypbind restart; sleep 15; service autofs reload' to my rc.local file
and then even after that, the automounts never get loaded until I log in as root
and reload them essentially a third time.
Comment 1 Jeremy Katz 2008-04-21 19:32:04 EDT
Are you using NetworkManager or the traditional network service?
Comment 2 Thomas J. Baker 2008-04-21 21:04:21 EDT
I'm using NM with a static IP address. I've been testing with that as I thought
it was going to be the default.
Comment 3 Jeremy Katz 2008-04-21 21:13:05 EDT
It is -- I think that for some cases like this where the link takes a few
seconds to come up, the thought is to add NETWORKWAIT or NETWORKDELAY in
/etc/sysconfing/network.  Adding notting and dcbw to the cc as I know I saw them
talking about it last week.
Comment 4 Bill Nottingham 2008-04-21 22:02:09 EDT
Adding NETWORKWAIT=yes to /etc/sysconfig/network should cause it to wait for the
network to be available.
Comment 5 Thomas J. Baker 2008-04-22 09:20:23 EDT
I'll try that. Another bug that causes problems for ypbind is
https://bugzilla.redhat.com/show_bug.cgi?id=443411 where disabling the firewall
with system-config-firewall doesn't really disable it. It makes broadcast
ypbinds fail.
Comment 6 Thomas J. Baker 2008-04-22 11:15:43 EDT
When Bill says 'should cause it to wait for the network', which 'it' is he
referring to? ypbind? I added NETWORKWAIT=yes to /etc/sysconfig/network and
rebooted but the only change I saw was when NetworkManager started; it printed
something like 'waiting for network'. ypbind started (and failed) way before NM
started, 10 to 15 services earlier.
Comment 7 Bill Nottingham 2008-04-22 11:43:03 EDT
If you have a system that has/was installed from an earlier rawhide, you may
need to run, once updating:

/sbin/chkconfig haldaemon resetpriorities
/sbin/chkconfig NetworkManager resetpriorities
Comment 8 Thomas J. Baker 2008-04-22 13:31:06 EDT
This system was installed last Friday with the preview release. I ran the resets
anyway and will try booting again after lunch.
Comment 9 Thomas J. Baker 2008-04-22 13:55:31 EDT
Resetting the priorities fixed it for me. YP now starts after NM and everything
works as expected.
Comment 10 Bill Nottingham 2008-04-22 14:07:11 EDT
OK, closing.
Comment 11 derrien 2008-04-25 08:40:36 EDT
With NM and DHCP to get nis domain and nis servers it doesn't work : there is no
/etc/yp.conf created like /sbin/dhclient-script made

NB: same pb with hostname. Our machines get their hostname from DCHP; with NM
that doesn't work anymore

Must I open new cases for these pbs ?
Comment 12 Bug Zapper 2008-05-14 05:51:18 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 13 derrien 2008-05-21 08:53:49 EDT
I solved this pb using the script directive in /etc/dhclient-XXX.conf:

script "/sbin/dhclient+nm-script";

with /sbin/dhclient+nm-script :
#!/bin/sh
/sbin/dhclient-script
/usr/libexec/nm-dhcp-client.action

But it would be fine if nm-dhcp-client.action make all the work...
Comment 14 Julian G 2008-07-18 17:47:35 EDT
NM doesn't recognize my wired network (e100 - intel 81801 BA/BAM/CA/CAM Rev 1).
nevertheless i get an ip from dhcp but ypbind refuses to connect. if i kill NM
and restart ypbind everything works fine.
Comment 15 Julian G 2008-12-20 20:59:31 EST
Does anybody care about this bug or should it be closed as "wontfix, because I don't want to"?
Comment 16 Bug Zapper 2009-06-09 20:19:39 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 17 Bug Zapper 2009-07-14 13:51:59 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.