Bug 443434 - X does not start on init 5. prefdm respawning too fast, stopped
X does not start on init 5. prefdm respawning too fast, stopped
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
i386 Linux
low Severity low
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-21 11:15 EDT by adam williams
Modified: 2014-03-16 23:14 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-21 12:55:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/xorg.0.log (24.83 KB, text/plain)
2008-04-21 11:15 EDT, adam williams
no flags Details

  None (edit)
Description adam williams 2008-04-21 11:15:02 EDT
Description of problem:

X does not start on init 5 but does start with startx.  Using Fedora 9
Pre-Release i386 (Fedora Release 8.93 (Rawhide) Kernel
2.6.25-0.234.rc9.git1.fc9.i686 on an i686)


Version-Release number of selected component (if applicable):

initscripts-8.70-1.i386 and event-compat-sysv-0.3.9-13.fc9.noarch.rpm

How reproducible:

every time system boots into run level 5 or I type init 5 at a root bash prompt.

Steps to Reproduce:
1.  boot system as normal, and see messages in /var/log/messages.
  
Actual results:

error message in /var/log/messages:

Apr 21 10:08:09 localhost init: prefdm main process (2819) terminated with status 1
Apr 21 10:08:09 localhost init: prefdm main process ended, respawning
Apr 21 10:08:10 localhost init: prefdm main process (2855) terminated with status 1
Apr 21 10:08:10 localhost init: prefdm main process ended, respawning
Apr 21 10:08:10 localhost init: prefdm main process (2891) terminated with status 1
Apr 21 10:08:10 localhost init: prefdm main process ended, respawning
Apr 21 10:08:11 localhost init: prefdm main process (2927) terminated with status 1
Apr 21 10:08:11 localhost init: prefdm main process ended, respawning
Apr 21 10:08:11 localhost init: prefdm main process (2963) terminated with status 1
Apr 21 10:08:11 localhost init: prefdm main process ended, respawning
Apr 21 10:08:12 localhost init: prefdm main process (2999) terminated with status 1
Apr 21 10:08:12 localhost init: prefdm main process ended, respawning
Apr 21 10:08:12 localhost init: prefdm main process (3035) terminated with status 1
Apr 21 10:08:12 localhost init: prefdm main process ended, respawning
Apr 21 10:08:12 localhost init: prefdm main process (3071) terminated with status 1
Apr 21 10:08:12 localhost init: prefdm main process ended, respawning
Apr 21 10:08:13 localhost init: prefdm main process (3107) terminated with status 1
Apr 21 10:08:13 localhost init: prefdm main process ended, respawning
Apr 21 10:08:13 localhost init: prefdm main process (3143) terminated with status 1
Apr 21 10:08:13 localhost init: prefdm main process ended, respawning
Apr 21 10:08:13 localhost init: prefdm respawning too fast, stopped


Expected results:

X to start normally and present me with graphical log in screen for KDE because
I used switchdesk kde previously.

Additional info:

attaching /var/log/Xorg.0.log because its 25K in size.

also in /etc/inittab I have:

x:5:respawn:/etc/X11/prefdm -nodaemon
Comment 1 adam williams 2008-04-21 11:15:02 EDT
Created attachment 303156 [details]
/var/log/xorg.0.log
Comment 2 Bill Nottingham 2008-04-21 12:08:57 EDT
Can you attach the gdm messages and logs as well?
Comment 3 adam williams 2008-04-21 12:18:06 EDT
(In reply to comment #2)
> Can you attach the gdm messages and logs as well?

/var/log/gdm/:0.log is dated 2008-04-09 and system date is Mon Apr 21 11:14:14
CDT 2008, so no point in attaching that file as it hasn't been modified in 12
days, and I just ran init 5.  grep gdm /var/log/* doesn't contain anything
useful, just info from from yum.log and rpmpkgs-200804* about when gdm was upgraded.

gdm is version 2.21.10-0.2008.04.11.3.fc9.i386 according to rpm -qa|grep gdm
Comment 4 Bill Nottingham 2008-04-21 12:23:28 EDT
Is there a greeter log in /var/log/gdm? Are you actually configured to use gdm?
Comment 5 adam williams 2008-04-21 12:42:03 EDT
(In reply to comment #4)
> Is there a greeter log in /var/log/gdm? Are you actually configured to use gdm?

there is not a greeter log in /var/log/gdm.  i'm specifying run level 5 in
/etc/inittab which should load gdm.

[root@localhost ~]# rpm -qa|grep gdm
fedorainfinity-gdm-theme-8.0.1-1.fc8.noarch
gdm-2.21.10-0.2008.04.11.3.fc9.i386
[root@localhost ~]# ls -l /var/log/gdm
total 20
-rw-r--r-- 1 root root 915 2008-04-09 18:25 :0.log
-rw-r--r-- 1 root root 915 2008-04-09 12:45 :0.log.1
-rw-r--r-- 1 root root 915 2008-04-07 10:35 :0.log.2
-rw-r--r-- 1 root root 915 2008-04-06 22:59 :0.log.3
-rw-r--r-- 1 root root 915 2008-04-05 13:40 :0.log.4
[root@localhost ~]# locate greeter
/etc/gconf/schemas/gdm-simple-greeter.schemas
/usr/include/kde/kgreeterplugin.h
/usr/libexec/gdm-simple-greeter
/usr/share/gdm/gdm-greeter-login-window.glade
/usr/share/kde4/apps/doc/kdm/greeter.dtd
Comment 6 Bill Nottingham 2008-04-21 12:46:10 EDT
What happens if you run prefdm by hand?

Can you attach /etc/sysconfig/desktop?
Comment 7 adam williams 2008-04-21 12:55:26 EDT
odd, /etc/sysconfig/desktop did not exist, so I created it with contents
DISPLAYMANAGER=KDE and DESKTOP=KDE and ran init 5 and it loads up with the GUI
login screen.  Thanks

Note You need to log in before you can comment on or make changes to this bug.