Bug 443442 - Font handling in aplus-fsf-4.22.1-2.fc8.i386
Font handling in aplus-fsf-4.22.1-2.fc8.i386
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: aplus-fsf (Show other bugs)
8
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Jochen Schmitt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-21 11:56 EDT by Tom Szczesny
Modified: 2008-07-30 16:10 EDT (History)
0 users

See Also:
Fixed In Version: 4.22.1-3.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-14 18:13:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Szczesny 2008-04-21 11:56:55 EDT
Description of problem:I have aplus-fsf running in 4 separate environments.

1)  Dell XPS Gen3 Tower with 32 bit Pentium
     Fedora      2.6.24.4-64.fc8
     aplus-fsf-4.22.1-2.fc8.i386
     xemacs-21.5.28-5.fc8.i386

2)  Dell XPS Gen3 Tower with 32 bit Pentium
     Fedora      2.6.23.15-80.fc7
     aplus-fsf-4.20.2-19.fc7.i386
     xemacs-21.5.38-3.fc7.i386

3)  HP Pavilion laptop with 64 bit Turion
     Fedora(64 bit)   2.6.24.4-64.fc8
     aplus-fsf-4.22.1-2.fc8.i386       (32 bit)
     xemacs-21.5.38-5.fc8.x86-64

4)  HP Pavilion laptop with 64 bit Turion
     Fedora(32 bit)   2.6.23.15-137.fc8
     aplus-fsf-4.20.2-22.fc8.i386
     xemacs-21.5.28.5.fc8.i386

I am having a problem in environments 1 & 3 which have the most recent version
of aplus.
When I bring up xemacs and attempt to choose the Kapl font, it is not available
in the drop-down box.

Since the Kapl font is available in environments 2 and 4, this does not appear
to be an xemacs problem.



Version-Release number of selected component (if applicable):
aplus-fsf-4.22.1-2.fc8.i386

How reproducible:
Start xemacs and attempt to activate Kapl font

Steps to Reproduce:
1. Install aplus-fsf-4.22.1-2.fc8.i386
2. Start up xemacs
3. Click on Options, then on Font.  The Kapl font does not appear in the list.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jochen Schmitt 2008-04-22 17:23:13 EDT
I have build aplus-fsf-4.22.1-3 for rawhide with some font packagine cleanup.
Comment 2 Fedora Update System 2008-04-23 14:24:25 EDT
aplus-fsf-4.22.1-3.fc7 has been submitted as an update for Fedora 7
Comment 3 Tom Szczesny 2008-04-27 13:56:05 EDT
I don't know where to find the updated code.  Comment#1 states that
aplus-fsf-4.22.1-3 was built for rawhide.  Comment#2 states that
aplus-fsf-4.22.1-3.fc7 was submitted for Fedora 7.  I started up my 32-bit f7
environment today and found no aplus-fsf update.  I started up my 64-bit f8
environment and found no update.  I checked two different mirror sites for
rawhide and found only aplus-fsf-4.22.1-2.fc9.i386.rpm.
Comment 4 Tom Szczesny 2008-04-27 22:24:11 EDT
I'm not sure that that it is worth updating Fedora 7 with
aplus-fsf-4.22.1-3.fc7.  The Kapl font does work with
aplus-fsf-4.20.2-19.fc7.i386 (although the "Enter" key does not in Xemacs when
editing an a+ file with the Kapl font).  It became impossible to select the Kapl
font beginning with aplus-fsf-4.22.1-2.fc8.i386.
Comment 5 Fedora Update System 2008-04-29 16:53:45 EDT
aplus-fsf-4.22.1-3.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update aplus-fsf'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F7/FEDORA-2008-3342
Comment 6 Tom Szczesny 2008-04-30 09:19:54 EDT
did not work - results were as follows:

$su -c 'yum --enablerepo=updates-testing update aplus-fsf'
Passowrd:
Usage: yum [options] < grouplist, localinstall, groupinfo, localupdate, 
resolvedep, erase, deplist, groupremove, makecache, upgrade, provides, shell, 
install, whatprovides, groupinstall, update, repolist, groupupdate, info, 
search, check-update, list, remove, clean, grouperase >

Command line error: no such option: --enablerepo
Comment 7 Tom Szczesny 2008-05-04 23:49:45 EDT
Was able to load package with yum when logged in as root.  After package was 
loaded the Kapl font was available in xemacs when logged in as regular user.  
However, the "Enter" key still did not work when editing an a+ file in xemacs 
using the Kapl font.
Comment 8 Fedora Update System 2008-05-14 18:13:55 EDT
aplus-fsf-4.22.1-3.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2008-07-30 16:10:49 EDT
aplus-fsf-4.22.1-3.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.