Bug 443459 - RFE: process explicit deps. before implicit ones to try to reduce pulling in extra deps.
RFE: process explicit deps. before implicit ones to try to reduce pulling in ...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Target
  Show dependency treegraph
 
Reported: 2008-04-21 13:35 EDT by Bastien Nocera
Modified: 2014-01-21 18:02 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-24 16:11:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yum-totem.txt (15.79 KB, text/plain)
2008-04-21 13:35 EDT, Bastien Nocera
no flags Details

  None (edit)
Description Bastien Nocera 2008-04-21 13:35:49 EDT
yum-3.2.14-10.fc9.noarch

Doing a "yum install totem" should be dragging in totem-gstreamer, not _both_
totem-gstreamer and totem-xine.

The main totem package has a requires on "totem-gstreamer", but the
libbaconvideowidget.so.0 dependency will resolve to totem-xine (because of the
shorter name?), so both packages will be installed.
Comment 1 Bastien Nocera 2008-04-21 13:35:49 EDT
Created attachment 303180 [details]
yum-totem.txt
Comment 2 James Antill 2008-04-21 13:43:26 EDT
 Yeh, one of the things we are thinking of doing, after Fed-9 is out, is
processing all the explicit dependencies first ... which should solve a couple
of the problems like this.
 Until something like that goes in though, it's going to stay as is.
Comment 3 Thomas J. Baker 2008-04-29 09:57:53 EDT
Too bad as it makes it seem like totem is completely busted. I couldn't figure
out why totem wouldn't play much of anything even though I had the other
gstreamer-based apps working fine. Turns out totem-xine was installed and was
mucking up the works. This on two systems from preview installs. I don't imagine
this could be fixed in the comps as the dependency would still be pulled in?
Comment 4 Bug Zapper 2008-05-14 05:52:30 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 James Antill 2008-08-07 14:50:50 EDT
This is also releated to: bug 442626
Comment 6 James Antill 2008-08-09 15:25:26 EDT
 A commit I just did today orders requires which I'm pretty sure will solve the above.
 upstream commit 92f360344742fa3fca38d97846cb7a31f3dd88bf
Comment 7 Bill Nottingham 2008-10-24 16:11:13 EDT
Verified.

Note You need to log in before you can comment on or make changes to this bug.