This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 443461 - FEAT: Match the new db schema of bz3.0 [2. TABLE bugs]
FEAT: Match the new db schema of bz3.0 [2. TABLE bugs]
Status: CLOSED CURRENTRELEASE
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Hardware Catalog (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: XINSUN
Yu Shao
:
Depends On:
Blocks: hwcert->BZ3_tracker
  Show dependency treegraph
 
Reported: 2008-04-21 13:46 EDT by XINSUN
Modified: 2008-08-04 13:56 EDT (History)
10 users (show)

See Also:
Fixed In Version: 3.2rh-20080801.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-04 13:56:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
The patch to fix the "rename the cust_facing,devel_whiteboard,fixed_in,internal_whiteboard,qa_whiteboard " (16.69 KB, patch)
2008-04-22 22:04 EDT, XINSUN
no flags Details | Diff
Patch Improve: (26.22 KB, patch)
2008-04-25 06:00 EDT, XINSUN
no flags Details | Diff
Patch improve: (29.37 KB, patch)
2008-04-29 06:10 EDT, XINSUN
no flags Details | Diff
The new clean patch (47.37 KB, patch)
2008-05-01 04:42 EDT, XINSUN
no flags Details | Diff

  None (edit)
Description XINSUN 2008-04-21 13:46:19 EDT
2. Relate to TABLE bugs  need to change.
Comment 1 XINSUN 2008-04-22 22:04:28 EDT
Created attachment 303408 [details]
The patch to fix the "rename the cust_facing,devel_whiteboard,fixed_in,internal_whiteboard,qa_whiteboard "

2.1 rename the
cust_facing,devel_whiteboard,fixed_in,internal_whiteboard,qa_whiteboard      
       Added :	    FIELD      bugs.cf_internal_whiteboard,
			       bugs.cf_devel_whiteboard,
			       bugs.cf_qa_whiteboard,
			       bugs.cf_fixed_in, 
			       bugs.cf_cust_facing
	Removed :   FIELD      bugs.cust_facing,
			       bugs.devel_whiteboard,
			       bugs.fixed_in,
			       bugs.internal_whiteboard,
			       bugs.qa_whiteboard
Comment 2 Rob Landry 2008-04-23 15:03:18 EDT
@@ -257,8 +257,7 @@ an "is_active" leaked into this patch
@@ -273,8 +272,7 @@ ditto
@@ -643,8 +643,7 @@

status_whiteboard didn't change?

@@ -1156,7 +1155,7 @@ parent_fixed_in doesn't really have to change; it's ok to
do so for consistancy but then we also need to search for all uses of
parent_fixed_in and verify they are all updated as well.

@@ -302,7 +302,7 @@ as above, all parent_ fields are internal to the sql not
directly in the field names.

@@ -483,11 +483,11 @@ ditto

Comment 3 XINSUN 2008-04-25 06:00:14 EDT
Created attachment 303768 [details]
Patch Improve:

1.Remove the "is_active" which was leaked into this patch.
2.Agree with Rob on "parent_fixed_in doesn't really have to change" and restore
the "parent_fixed_in.
3.Add some changes for post.cgi.
Comment 4 Noura El hawary 2008-04-27 23:38:32 EDT
> status_whiteboard didn't change?
> 

status_whiteboard deosn't change as it is not a custom field it exists as a main
database field in the upstream bugs database schema and not something that was
created or customized by redhat like the fields:
cust_facing,devel_whiteboard,fixed_in,internal_whiteboard,qa_whiteboard

those now require cf_* for custom field to be added to the front of the column name.
Comment 5 XINSUN 2008-04-29 06:10:40 EDT
Created attachment 304089 [details]
Patch improve:

1.Add the field: cust_facing 
2.Add the file for search function: query.cgi,
template/en/default/search/form_advanced.html.tmpl

Please review,
Nicho
Comment 6 Noura El hawary 2008-04-30 23:06:11 EDT
Hi nicho,

there are few places in the hwcert code that still has the custom field names
without cf_* specially in the templates. you can use something like this command
to check those places that are still not changes after you apply your patch:

# grep -rn devel_whiteboard .

also one question: Is the following template :
template/en/default/search/form_hwcert.html.tmpl
used in hwcert ? is there a search page or functionality in hwcert that will
involve those cf_* fields? 

Thanks,
Noura
Comment 7 XINSUN 2008-05-01 04:41:40 EDT
Hi Noura,
Thanks  for your feedback. :)
template/en/default/search/form_hwcert.html.tmpl is not used in hwcert, I can
remove it from repo. The search page or functionality in hwcert that will
involve those cf_* fields were fixed in that patch, I will paste a new clean
patch  for it.
Those few places which still have the custom field names without cf_* work well
because I use  $var->{bug->devel_whiteboard} in Bugzilla/Bug.pm. but for the
consistency of naming, I changed them and add these changes in the new clean
patch too. I have tested this patch and it works well.

Nicho
Comment 8 XINSUN 2008-05-01 04:42:24 EDT
Created attachment 304300 [details]
The new clean patch
Comment 9 Noura El hawary 2008-05-01 09:14:31 EDT
patch looks good to me nicho.

Noura
Comment 10 Rob Landry 2008-07-17 17:02:12 EDT
Please commit this change to CVS and set the status to MODIFIED.
Comment 11 eric_liu 2008-08-01 07:19:02 EDT
tested and run good 

Note You need to log in before you can comment on or make changes to this bug.