Bug 443464 - Evolution not able to forward / reply / reply to all messages
Evolution not able to forward / reply / reply to all messages
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: evolution-exchange (Show other bugs)
9
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-21 13:52 EDT by Rolf Linder
Modified: 2008-09-10 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-10 12:36:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rolf Linder 2008-04-21 13:52:18 EDT
Description of problem:
I'm using Fedora9Beta (details see below) with evolution and exchange plugin.
Since Fedora7 I'm using this plugin at work to have a Fedora Desktop as my
workstation...

Now I've detected at home, that with the new fedora9 and evolution-exchange
you're not able to forward/reply or reply to all any message because
gnome-keyring-daemon uses nearly 100% cpu for about 10s and then evolution does
not respond any more....

here are my system specs:

Linux wks01 2.6.25-1.fc9.x86_64 #1 SMP Thu Apr 17 01:11:31 EDT 2008 x86_64
x86_64 x86_64 GNU/Linux

Fedora release 8.93 (Rawhide)

evolution-exchange-2.22.1-1.fc9.x86_64
evolution-2.22.1-1.fc9.x86_64
evolution-data-server-2.22.1-1.fc9.x86_64
evolution-webcal-2.21.92-1.fc9.x86_64

last updated today (2008/04/21)




Version-Release number of selected component (if applicable):
evolution-exchange-2.22.1-1.fc9.x86_64

How reproducible:
always

Steps to Reproduce:
1. Setup a Fedora9; install evolution-exchange plugin
2. Confugure a Exchange Account ; setup gnome-keyring for passwords
3. Try to forward a message

 
Actual results:
Evolution is not responding any more....need to destroy

Expected results:
Forwarding E-Mail ;)

Additional info:

since F7 (FC6) until F8 (currently on my workstation) I do not have any issues
with this. It came up with the new F9...

Console output when forwarding a mail (trying...):

(evolution:11521): composer-CRITICAL **: set_editor_signature: assertion
`account != NULL' failed

(evolution:11521): composer-CRITICAL **: set_editor_signature: assertion
`account != NULL' failed

** (evolution:11521): WARNING **: couldn't connect to daemon at
$GNOME_KEYRING_SOCKET: /tmp/keyring-eoZL4M/socket: Connection refused

** (evolution:11521): WARNING **: couldn't connect to daemon at
$GNOME_KEYRING_SOCKET: /tmp/keyring-eoZL4M/socket: Connection refused

** (evolution:11521): WARNING **: couldn't connect to daemon at
$GNOME_KEYRING_SOCKET: /tmp/keyring-eoZL4M/socket: Connection refused

** (evolution:11521): WARNING **: couldn't connect to daemon at
$GNOME_KEYRING_SOCKET: /tmp/keyring-eoZL4M/socket: Connection refused

** (evolution:11521): WARNING **: couldn't connect to daemon at
$GNOME_KEYRING_SOCKET: /tmp/keyring-eoZL4M/socket: Connection refused

** (evolution:11521): WARNING **: couldn't connect to daemon at
$GNOME_KEYRING_SOCKET: /tmp/keyring-eoZL4M/socket: Connection refused

** (evolution:11521): WARNING **: couldn't connect to daemon at
$GNOME_KEYRING_SOCKET: /tmp/keyring-eoZL4M/socket: Connection refused

** (evolution:11521): WARNING **: couldn't connect to daemon at
$GNOME_KEYRING_SOCKET: /tmp/keyring-eoZL4M/socket: Connection refused

** (evolution:11521): WARNING **: couldn't connect to daemon at
$GNOME_KEYRING_SOCKET: /tmp/keyring-eoZL4M/socket: Connection refused

** (evolution:11521): WARNING **: couldn't connect to daemon at
$GNOME_KEYRING_SOCKET: /tmp/keyring-eoZL4M/socket: Connection refused
Comment 1 Matthew Barnes 2008-04-21 15:05:47 EDT
The warnings indicate your keyring daemon is either not running or
misconfigured. That said, Evolution has a problem with not taking 'no' for an
answer, and tends to keep trying indefinitely.

Try opening System -> Preferences -> System -> Keyring Manager and see if you
encounter any issues.  That should tell us if it's misconfigured.
Comment 2 Rolf Linder 2008-04-22 11:02:45 EDT
Hi, thanks for your reply!

No, I already did that. I checked, that access to the credentials in Keyring
Manager is possible....the keyrings are also unlocked...
Comment 3 Rolf Linder 2008-09-10 12:36:15 EDT
since latest installations problem was never seen again...

Note You need to log in before you can comment on or make changes to this bug.