This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 443497 - Constant subroutine main::AF_INET6 redefined at /usr/lib/perl5/5.10.0/Exporter.pm
Constant subroutine main::AF_INET6 redefined at /usr/lib/perl5/5.10.0/Exporte...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl-Socket6 (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Robert Scheck
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-21 16:56 EDT by Robert Scheck
Modified: 2008-04-22 15:45 EDT (History)
3 users (show)

See Also:
Fixed In Version: 0.20-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-22 15:45:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2008-04-21 16:56:50 EDT
Description of problem:
$ /etc/init.d/sip-redirect restart
Stopping sip-redirect:                                     [  OK  ]
Starting sip-redirect: Constant subroutine main::AF_INET6 redefined at
/usr/lib/perl5/5.10.0/Exporter.pm line 66.
 at /usr/bin/sip-redirect line 55
Prototype mismatch: sub main::AF_INET6 () vs none at
/usr/lib/perl5/5.10.0/Exporter.pm line 66.
 at /usr/bin/sip-redirect line 55
Constant subroutine main::PF_INET6 redefined at
/usr/lib/perl5/5.10.0/Exporter.pm line 66.
 at /usr/bin/sip-redirect line 55
Prototype mismatch: sub main::PF_INET6 () vs none at
/usr/lib/perl5/5.10.0/Exporter.pm line 66.
 at /usr/bin/sip-redirect line 55
                                                           [  OK  ]
$

Version-Release number of selected component (if applicable):
perl-Socket6-0.19-7

How reproducible:
Everytime since perl 5.10.0.

Actual results:
Messages like "Constant subroutine main::AF_INET6 redefined at
/usr/lib/perl5/5.10.0/Exporter.pm"

Expected results:
Silence as before... ;-)

Additional info:
Upgrade to Socket6 in version 0.20 solves the problem. I'll commit the update
to CVS once it got reanimated after the F-9 branching.
Comment 1 Robert Scheck 2008-04-22 13:15:46 EDT
Package: perl-Socket6-0.20-1.fc9 Tag: dist-f9 Status: complete
Package: perl-Socket6-0.20-1.fc10 Tag: dist-f10 Status: complete

Requested, that perl-Socket6-0.20-1.fc9 makes it directly into F9 final.

Note You need to log in before you can comment on or make changes to this bug.