Bug 443502 - RPM/yum hangs
RPM/yum hangs
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
9
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-21 17:15 EDT by Mathieu Bridon
Modified: 2008-08-16 23:02 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-16 23:02:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mathieu Bridon 2008-04-21 17:15:00 EDT
Description of problem:
When trying to install something, RPM/yum hang infinitely.

Version-Release number of selected component (if applicable):
# rpm -q rpm
rpm-4.4.2.3-2.fc9.x86_64
# rpm -q yum
yum-3.2.14-10.fc9.noarch


How reproducible:
Always for some packages

Steps to Reproduce:
1. yum install xchat-gnome
2. yum will download the RPMs and try to install it
  
Actual results:
yum will hang on running the transaction (before installing the package).


Expected results:
yum should install the package.

Additional info:
I thought at first it was yum, but then I tried this:
# yumdoanloader xchat-gnome
...
xchat-gnome-0.18-12.fc9.x86_64.rpm                       | 1.6 MB     00:32 
# rpm -ivh xchat-gnome-0.18-12.fc9.x86_64.rpm 
attention: xchat-gnome-0.18-12.fc9.x86_64.rpm: Entête V3 DSA signature: NOKEY,
key ID 4f2a6fd2

And then rpm hangs...

Could it be that RPM can't install unsigned packages?

It doesn't happen on every packages (I was able to do an update with PackageKit,
ie with yum).

While it's hung, I get the following:
# top -b -n 1 -p 14008
top - 23:12:18 up  1:21,  4 users,  load average: 1.03, 0.81, 0.87
Tasks:   1 total,   0 running,   1 sleeping,   0 stopped,   0 zombie
Cpu(s):  6.9%us,  1.7%sy,  0.0%ni, 89.0%id,  2.3%wa,  0.0%hi,  0.0%si,  0.0%st
Mem:   2052776k total,  1908300k used,   144476k free,    74004k buffers
Swap:  1051700k total,        0k used,  1051700k free,  1090340k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND           
                                                                             
14008 root      20   0  344m  74m 8764 D  0.0  3.7   0:05.87 yum               
                                                                             

(the %CPU and %MEM remains absolutely constant over time)
Comment 1 Mathieu Bridon 2008-04-22 15:55:03 EDT
Ok, it's been happening since I installed Fedora 9 preview this week end.

I just switched my laptop on, both yum and rpm install the exact same packages
that were hanging previously :-/

That's really weird, I've been trying to "yum clean all", rebuild rpm db,
reboot, etc... And the issue was always the same. And now, it seems to be simply
gone.

Sorry for having opened the bug report.
Comment 2 Jeff Johnson 2008-04-23 09:30:14 EDT
This is likely a stale futex from the kernel.

Only a reboot can clear stale futexes unless robust mutexes are used.

There's a patch to use robust mutexes in rpm-4.4.9+ sources.


Comment 3 Bug Zapper 2008-05-14 05:53:29 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Mathieu Bridon 2008-06-10 06:19:45 EDT
I'm wondering if this bug isn't somehow related to the fsync bug in Firefox,
which is related to the sqlite behaviour.

As yum uses sqlite IIRC, and as the symptoms are identical (the application
freezes, no CPU used, no / few memory used), I thought it might by a interesting
track to investigate.

However, as I said previously, this doesn't happen anymore...
Comment 5 Kevin 2008-08-16 23:02:40 EDT
Closing bug as the reporter has indicated that the issue is resolved.

Note You need to log in before you can comment on or make changes to this bug.