Bug 443507 - (alfoqui) logging as no root get message device /dev/dsp can't be opened (Permission denied)
logging as no root get message device /dev/dsp can't be opened (Permission de...
Product: Fedora
Classification: Fedora
Component: ConsoleKit (Show other bugs)
i686 Linux
low Severity high
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-04-21 17:38 EDT by alfonso quiroga
Modified: 2013-03-05 22:55 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-01-09 01:24:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description alfonso quiroga 2008-04-21 17:38:02 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; es-ES; rv: Gecko/20080325 Fedora/ Firefox/

Description of problem:
when i log as root i have no problem using any player (amarok,rhymtbox,) but when i log as another user i get the message  device /dev/dsp can't be opened (Permission denied)

Version-Release number of selected component (if applicable):
kernel-, alsa-utils-1.0.15-1.fc8

How reproducible:

Steps to Reproduce:
1.turn on the computer
2.log as any user different as root

Actual Results:

Expected Results:

Additional info:
Comment 1 Rex Dieter 2008-04-22 11:39:39 EDT
How are you logging in?  
gdm and kdm use ConsoleKit to properly set /dev/* permissions.  If you're using 
some other method, that's it.
Else, ConsoleKit isn't properly doing its thing, for some reason.
Comment 2 Kevin Kofler 2008-04-22 11:45:30 EDT
Plain console login (runlevel 3) is also supposed to work with ConsoleKit.
Comment 3 Rex Dieter 2008-04-22 11:49:13 EDT
really?  coulda sworn I've seen a few reports of "console login + startkde" not
working for precisely this reason. ??
Comment 4 Kevin Kofler 2008-04-22 11:54:44 EDT
"supposed to" doesn't necessarily mean it actually works. ;-)

AFAIK, the PAM setup to register runlevel 3 sessions with ConsoleKit is there, 
it might not be working though.
Comment 5 alfonso quiroga 2008-04-22 12:26:35 EDT
i use kdm and kde 3.5.9-5. i've console-kit running in runlevel 3 & 5, but
/dev/dsp & /dev/mixer has permision denied for other users. i've tried to change
permision and restart sound system but again i found /dev/* with permissions
denied. I've also tried to modify /etc/security/console.perms.d/50-defult with 

<sound>=/dev/dsp* /dev/snd/*

<console> 0666 <sound>       0600 root

and it didn't work.
Comment 6 alfonso quiroga 2008-04-23 15:21:16 EDT
i've changed permission to /dev/dsp and /dev/mixer and without restart sound
sytem  icould play amarok but i hadn't sound in firefox
Comment 7 alfonso quiroga 2008-04-24 12:58:53 EDT
i've just discover that i can't either access to /dev/sr0 (my burning dvd) with
K3b, i've changed permissions and i can. So i think that is a problem of
consolekit. ¿How can i fix this bug? I've read the consolekit.conf and i cant
undestand anything.
Comment 8 Rex Dieter 2008-04-24 13:03:36 EDT
Let see if the kind ConsoleKit folks can help diagnose why this isn't working
properly for you.
Comment 9 Bug Zapper 2008-11-26 05:32:09 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 10 Bug Zapper 2009-01-09 01:24:28 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.