Bug 443523 - ant does not load libraries from ~/.ant/lib
ant does not load libraries from ~/.ant/lib
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: ant (Show other bugs)
5.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Permaine Cheung
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-21 19:07 EDT by Trevin Beattie
Modified: 2013-12-16 14:48 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-16 14:48:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Trevin Beattie 2008-04-21 19:07:40 EDT
Description of problem:
I have a Java project which requires 3rd-party ant tasks in order to build. 
I've tried installing the optional ant libraries in ~/.ant/lib,
/usr/share/java/ant, /usr/share/ant/lib, and /usr/share/java, but ant fails to
load them.

Version-Release number of selected component (if applicable):
ant-1.6.5-2jpp.2

I've also tried ant-1.7.0-1jpp.4 from the Fedora Core 8 distribution, and it
fails as well.  ant-1.6.2 from FC4 works, but I'm told by an ASF developer that
that version's behavior is invalid.

How reproducible:
Every time

Steps to Reproduce:
1. Go to http://ant.apache.org/ivy/download.cgi and download and extract
apache-ivy-2.0.0-beta2-bin.tar.gz
2. cd apache-ivy-2.0.0-beta2
3. mkdir -p ~/.ant/lib
4. cp ivy-2.0.0-beta2.jar ~/.ant/lib/
5. cd src/example/hello-ivy
6. ant
  
Actual results:
Buildfile: build.xml

resolve:
BUILD FAILED
/home/tbeattie/src/apache-ivy-2.0.0-beta2/src/example/hello-ivy/build.xml:38:
Problem: failed to create task or type antlib:org.apache.ivy.ant:retrieve
Cause: The name is undefined.
Action: Check the spelling.
Action: Check that any custom tasks/types have been declared.
Action: Check that any <presetdef>/<macrodef> declarations have taken place.

This appears to be an antlib declaration. 
Action: Check that the implementing library exists in one of:
        -/usr/share/ant/lib
        -/home/tbeattie/.ant/lib
        -a directory added on the command line with the -lib argument


Expected results:
Buildfile: build.xml

resolve:
No ivy:settings found for the default reference 'ivy.instance'.  A default
instance will be used
     [null] no settings file found, using default...
     [null] :: Ivy 2.0.0-beta2 - 20080225093827 :: http://ant.apache.org/ivy/ ::
     [null] :: loading settings :: url =
jar:file:/home/tbeattie/.ant/lib/ivy-2.0.0-beta2.jar!/org/apache/ivy/core/settings/ivysettings.xml
[ivy:retrieve] :: resolving dependencies ::
org.apache#hello-ivy;working@ernie.boingo.com
[ivy:retrieve]  confs: [default]
[ivy:retrieve]  found commons-lang#commons-lang;2.0 in public
[ivy:retrieve]  found commons-cli#commons-cli;1.0 in public
[ivy:retrieve]  found commons-logging#commons-logging;1.0 in public
[ivy:retrieve] :: resolution report :: resolve 140ms :: artifacts dl 5ms
[ivy:retrieve]  :: evicted modules:
[ivy:retrieve]  commons-lang#commons-lang;1.0 by [commons-lang#commons-lang;2.0]
in [default]
        ---------------------------------------------------------------------
        |                  |            modules            ||   artifacts   |
        |       conf       | number| search|dwnlded|evicted|| number|dwnlded|
        ---------------------------------------------------------------------
        |      default     |   4   |   0   |   0   |   1   ||   3   |   0   |
        ---------------------------------------------------------------------
[ivy:retrieve] :: retrieving :: org.apache#hello-ivy
[ivy:retrieve]  confs: [default]
[ivy:retrieve]  0 artifacts copied, 3 already retrieved (0kB/5ms)

run:
     [java] standard message : hello ivy !
     [java] capitalized by org.apache.commons.lang.WordUtils : Hello Ivy !

BUILD SUCCESSFUL


Additional info:
The problem was first discovered with JPackage rpm's in ant-1.6.4 here:
https://issues.apache.org/bugzilla/show_bug.cgi?id=35060

In this new entry it was explained why this is not an ant bug:
https://issues.apache.org/bugzilla/show_bug.cgi?id=44849

Note You need to log in before you can comment on or make changes to this bug.