Bug 443536 - gcc 4.3.0-7 segfaults building wine
gcc 4.3.0-7 segfaults building wine
Status: CLOSED DUPLICATE of bug 440139
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
rawhide
i386 Linux
low Severity low
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-21 21:39 EDT by Henry Kroll
Modified: 2008-04-22 10:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-22 10:54:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Henry Kroll 2008-04-21 21:39:24 EDT
Description of problem:
When compiling latest wine_git:



Version-Release number of selected component (if applicable):


How reproducible:
Install Fedora 9 beta from Live CD and install to HD.
Download src rpm of wine.
Set up build environment and attempt to build wine rpm.
rpmbuild --rebuild wine*rpm #This process will warn you about any missing libraries.
Install the missing libraries through yum and try again.
rpmbuild --rebuild wine*rpm
When gcc crashes, attempt to download wine source from git.
It will crash again. Truncated output:

Steps to Reproduce:
1.Download wine from git repository.
2../tools/wineinstall
3.wait for goats to appear
  
Actual results:

{standard input}:7531: Warning: end of file not at end of a line; newline inserted
{standard input}:8093: Error: unknown pseudo-op: `.lb'
gcc: Internal error: Segmentation fault (program cc1)
Please submit a full bug report.

Expected results:

Exit 0

Additional info:

Same tarball builds fine on Fedora 8/gcc 4.1

If I get time, I may try to triage this, build a stock gcc from git, bypassing
any vendor-specific patch sets.
Comment 1 Jakub Jelinek 2008-04-22 10:54:54 EDT

*** This bug has been marked as a duplicate of 440139 ***

Note You need to log in before you can comment on or make changes to this bug.