Bug 443543 - HP DC7800MT BIOS Error?
HP DC7800MT BIOS Error?
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.1
x86_64 Linux
low Severity urgent
: ---
: ---
Assigned To: Tony Camuso
Martin Jenner
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-22 00:23 EDT by Mark Zhang
Modified: 2008-10-15 08:05 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-15 08:05:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Snapshot for the boot screen (361.95 KB, image/pjpeg)
2008-04-22 00:23 EDT, Mark Zhang
no flags Details

  None (edit)
Description Mark Zhang 2008-04-22 00:23:02 EDT
Description of problem:
Cannot install the Redhat Enterprise Linux Server 5.1 in HP DC7800CMT

Version-Release number of selected component (if applicable):
2.6.18-53.el5

How reproducible:
Install process with DVD and press Enter to install

Steps to Reproduce:
1.Boot PC and insert Installation DVD
2.At the menu, press Enter
3.
  
Actual results:
The PC will hung 

Expected results:
Normal Install process

Additional info:
Install with "acpi=off" and pass. But when start PC, got error message in 
Attachment.BIOS bug
Comment 1 Mark Zhang 2008-04-22 00:23:02 EDT
Created attachment 303255 [details]
Snapshot for the boot screen
Comment 2 Jeff Garzik 2008-04-24 07:03:12 EDT
Have you tried updating BIOS?

As the message indicates, Linux kernel is downloading information from your BIOS
that is necessary to use your computer.  If your BIOS is giving incorrect
information, then it is easily possible for Linux to misprogram the hardware
based on bad information.
Comment 3 Tony Camuso 2008-04-24 09:02:33 EDT
Mark,

"BIOS bug" message indicates you need to update your BIOS.

Have you booted Linux on this system before? If so, which version(s)

Is this new behavior?

Comment 4 Mark Zhang 2008-04-24 10:06:14 EDT
(In reply to comment #3)
> Mark,
> "BIOS bug" message indicates you need to update your BIOS.
> Have you booted Linux on this system before? If so, which version(s)
> Is this new behavior?

I never boot this type PC before. But I update the BIOS yesterday. 
The old BIOS is 1.04 and now I update to the lastest 1.24 from HP.
But the same problem exists. 
Comment 5 Mark Zhang 2008-04-24 10:17:23 EDT
(In reply to comment #2)
> Have you tried updating BIOS?
> As the message indicates, Linux kernel is downloading information from your 
BIOS
> that is necessary to use your computer.  If your BIOS is giving incorrect
> information, then it is easily possible for Linux to misprogram the hardware
> based on bad information.

I called HP and I found the information that DC7800 is the certified type for 
RHEL 5.0 by its partner in HP's website.
http://h71028.www7.hp.com/enterprise/cache/317386-0-0-14-121.html
It should support by Redhat. Do you tried this type before. 
I also update the BIOS to the lastest 1.24 and still have the issue.
Comment 6 Tony Camuso 2008-04-24 19:16:05 EDT
The DC7800MT is *NOT* certified for RHEL5.0, only RHEL5.1

Please use RHEL5.1 on the DC7800MT.

Thank you.
Comment 7 Mark Zhang 2008-04-24 21:24:54 EDT
(In reply to comment #6)
> The DC7800MT is *NOT* certified for RHEL5.0, only RHEL5.1
> 
> Please use RHEL5.1 on the DC7800MT.
> 
> Thank you.
> 
Have  you tried to install RHEL5.1 in HP DC7800 with the common way? 

YES. In the website, it said RHEL5. But I installed the lastest Redhat RHEL5.1.
The same problem exist. Are you sure it is not a software bug? Bios bugs?  
I have to use the especial command to make a successfully installation. It is a
very professional installation way. I do not like it. 
And I do not think HP can say it passed the certification because it use the
professional installation way.
Comment 8 Tony Camuso 2008-04-25 08:59:23 EDT
Mark, 

What do you have to do to install RHEL5.1 on the DC7800MT?

You mention that you are using a special way to successfully install. 

Is this a boot line command that you need? If so, what is the boot line command?

Is it pci=nommconf or pci=nobfsort or is it something else?
Comment 9 Tony Camuso 2008-08-13 16:04:27 EDT
Mark, 

Please respond. 

Are you using a boot command option?

If so, my guess is it's either pci=nommconf or pci=nobfsort
Comment 10 Tony Camuso 2008-10-15 08:05:45 EDT
I'm closing this bug, as Mark has not replied to my questions.

Note You need to log in before you can comment on or make changes to this bug.