Bug 443545 - Wireless device DWL-G520 Rev. B4 supported by ath5k is not displayed by anaconda
Wireless device DWL-G520 Rev. B4 supported by ath5k is not displayed by anaconda
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-22 01:35 EDT by Joachim Frieben
Modified: 2009-01-20 05:01 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 05:01:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2008-04-22 01:35:31 EDT
Description of problem:
After booting from the latest boot.iso and choosing the http install
method, the two wired devices eth0/eth1 present on the system are
displayed in order to choose the one to be used during install. The
also present wireless device wlan0 which is supported by ath5k does
not show up.

Version-Release number of selected component (if applicable):
anaconda-11.4.0.75-1

How reproducible:
Always.

Steps to Reproduce:
1. Boot from boot.iso.
2. Choose http install.
  
Actual results:
Only wired devices are displayed.

Expected results:
The wireless one is shown, too.

Additional info:
The wireless adapter is a D-Link DWL G510 PCI card based upon the Atheros
AR2413 chipset which has been supported by F8 and "rawhide" for almost
three months now. Adding "essid=XXXX" and "wepkey=YYYY" on the boot line
has no effect either.
Comment 1 Chris Lumens 2008-04-22 05:20:12 EDT
Wireless adapters may be shown by adding the 'allowwireless' command line option
to anaconda when booting the installer.  Let us know if adding this option still
requires firmware that isn't present in the initrd.  Thanks.
Comment 2 Joachim Frieben 2008-04-22 06:57:12 EDT
Adding 'allowwireless' to the boot options has no effect. The 'ath5k'
driver does not have separate firmware. I would thus guess that the
module itself is simply missing.
Comment 3 Chris Lumens 2008-04-22 10:27:58 EDT
Yep, this module and several other wireless modules are missing for some reason.
Comment 4 Joachim Frieben 2008-04-22 11:43:06 EDT
If 'some' reason is related to the rather 'work in progress' character
of this driver, I would suggest to include anyway, since wireless install
is a quasi-experimental feature which needs to be enabled explicitly.
The ath5k driver is perfectly usable for me on a permanent basis. Madwifi
is long gone from my system now.
Comment 5 Bug Zapper 2008-05-14 05:54:42 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Andy Lindeberg 2008-06-03 10:15:18 EDT
Are the wireless modules still missing, or have they been included?
Comment 7 Joachim Frieben 2008-06-11 16:02:53 EDT
Browsing through initrd.img of today's boot.iso, ath5.ko turns out to
be still missing [2.6.26-0.57.rc5.git3.fc10.x86_64].
Comment 8 Chris Lumens 2008-06-13 14:46:15 EDT
ath5k and several other wireless modules are explicitly excluded from the
install images because they were broken at some point in the past.  This is
definitely worth testing again to see what the status of these drivers is.
Comment 9 Joachim Frieben 2008-08-09 02:12:25 EDT
The F10 alpha netinst image still does not contain the ath5k module. When can we expect it to be included? The driver has left the experimental status for a while now.
Comment 10 Chris Lumens 2008-08-11 10:24:19 EDT
I've re-enabled the wireless modules in Rawhide for now.  You need to boot with the "allowwireless" parameter to get loader to use them.  If the module dependency situation with these modules is still as busted as it was when we first disabled them, they might have to come back out however.

Please give a test with Rawhide and let me know if this works for you.
Comment 11 Joachim Frieben 2008-08-14 16:07:00 EDT
After downloading the latest boot.iso from the "rawhide" tree and adding "allowwireless" to the installer options, anaconda reports that no device has been found. The driver selection list allows to choose support for Atheros 5xxx devices. But after selecting the latter, one is prompted again to choose a driver. The installer output at this point reads:

  ath5k_pci 0000:01:0a.0: registered as 'phy0'
  phy0: Selected rate control algorithm 'pid'
  phy0: Failed to initialize wep: -2
  ath5k phy0: can't register ieee80211 hw
  ath5k_pci: 0000:01:0a.0: PCI Int A disabled
  ath5k_pci: probe of 0000:01:0a.0 failed with error -2

The D-Link DWL-G520 Rev. B4 WLAN device is supported by the ath5k driver [Fedora] since January 2008.
Comment 12 Joachim Frieben 2008-09-08 11:36:00 EDT
Observations of comment #11 still apply to "rawhide" as of 2008-09-08.
Comment 13 John W. Linville 2008-09-08 13:32:31 EDT
Chris, what modules did you include?  Comment 11 looks like ecb and/or arc4 are missing.  We probably want aes_generic as well if we are supporting WPA encryption in the installer.
Comment 14 Chris Lumens 2008-09-08 14:12:04 EDT
We were already including aes_generic, but I've now added the ecb and arc4 modules.  Those will be in rawhide after the next build of anaconda.  Anything else I might be missing?
Comment 15 John W. Linville 2008-09-08 14:42:23 EDT
I think that should cover it -- those are the cypto modules that mac80211 can request.
Comment 16 Joachim Frieben 2008-09-12 16:45:22 EDT
Installing from boot.iso as of 2008-09-12 works as expected.
Comment 17 Joachim Frieben 2009-01-11 12:06:14 EST
Support for Atheros AR2413 is again broken in current "rawhide" as of 2009-01-10 sporting anaconda-11.5.0.6-1 [boot options "allowwireless", "essid=..." and "wepkey=..." had been added].
Moreover, not only the Atheros driver is unavailable: even the 2nd wired device eth1: Tigon3 [partno(BCM95721) rev 4101 PHY(5750)] is not available for selection. Accordingly, the menu for device selection is not presented at all. The boot log simply states that only eth0 which is using the forcedeth driver is present.
The mainboard is a Tyan Tomcat K8E (S2865-AG2NRF).

Note You need to log in before you can comment on or make changes to this bug.