Bug 443546 - Intel video driver doesn't handle widescreen LCD under KDE
Intel video driver doesn't handle widescreen LCD under KDE
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
9
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-22 02:00 EDT by Patrick O'Callaghan
Modified: 2008-09-29 08:25 EDT (History)
6 users (show)

See Also:
Fixed In Version: 4.1.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-29 08:25:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X11 startup log (26.95 KB, text/plain)
2008-04-22 02:00 EDT, Patrick O'Callaghan
no flags Details
xorg.conf, for completeness (755 bytes, text/plain)
2008-04-22 02:22 EDT, Patrick O'Callaghan
no flags Details

  None (edit)
Description Patrick O'Callaghan 2008-04-22 02:00:56 EDT
Description of problem:


Version-Release number of selected component (if applicable):
xorg-x11-drv-i810.x86_64

How reproducible:
Boot and login

Steps to Reproduce:
1.Log in with KDE 4
2.Screen is stretched to fit 1440x900 LCD display
3.Settings->Display gives black screen, have to kill X to recover
  
Actual results:
Stretched 4x3 aspect ratio

Expected results:
16x9 aspect ratio

Additional info: configured with system-config-display to use 1440x900. Video is
Intel 965G on Intel mobo. Screen is Samsung 920NM LCD. See attached Xorg.0.log.
Under Gnome the display can be adjusted correctly (via xrandr), but settings are
not preserved on logging out.
Comment 1 Patrick O'Callaghan 2008-04-22 02:00:56 EDT
Created attachment 303262 [details]
X11 startup log
Comment 2 Patrick O'Callaghan 2008-04-22 02:21:09 EDT
KDE->Leave->Lock Screen also gives the black screen. It recovers if I kill
krunner_lock.
Comment 3 Patrick O'Callaghan 2008-04-22 02:22:55 EDT
Created attachment 303267 [details]
xorg.conf, for completeness
Comment 4 Patrick O'Callaghan 2008-04-22 10:25:45 EDT
Tried the F9 Live CD on the same machine. This time it worked correctly
(1440x900) using the internal video driver (there is no xorg.conf by default). I
could also use the Settings->Display widget without error. Going back to
F9-Preview, I removed xorg.conf and restarted, but the error is still there.

I notice that when the display goes black there is apparently a desktop still
present. The cursor changes shape (arrow or I-beam) according to where it is on
the screen. I just can't see anything except the cursor.
Comment 5 Patrick O'Callaghan 2008-04-22 11:10:20 EDT
I just discovered the real cause of my problem. I'm a longtime KDE user, so in
my new F9 I just logged into my account as always, and of course it has all the
setup for KDE 3.5. Removing a few lines from .kde/share/config/startupconfig
(the ones to do with randr) basically fixed the aspect ratio problem.

I still have the Settings->Display problem but that may also be related to KDE
3.5. I set up a fresh test account and it doesn't have this issue.
Comment 6 Matěj Cepl 2008-04-24 06:40:56 EDT
Could you be more specific which lines of .kde/share/config/startupconfig
you have removed? We can put it into Release Notes or something.

However, reassigning to KDE component, because it looks like something to do
with migration between KDE versions.
Comment 7 Patrick O'Callaghan 2008-05-08 00:32:20 EDT
Sorry. I only just noticed this request because the problem returned after
updating to xorg-x11-server-Xorg-1.4.99.901-29.20080415.fc9.x86_64. The lines I
commented out are all those beginning kcmrandrrc*

Comment 8 Bug Zapper 2008-05-14 05:54:48 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Steven M. Parrish 2008-06-23 16:38:44 EDT
Still having this problem or has it fixed itself?
Comment 10 Patrick O'Callaghan 2008-07-23 20:27:47 EDT
The display resolution bug is still present, but in KDE 4.0.98-2.fc9.x86_64 it
has changed somewhat:

1) On logging in, the screen aspect ratio is wrong (looks like approx. 1024x768
instead of 1440x900), and windows are stretched horizontally to fill the space.

2) Opening Settings->Display instantly corrects the aspect ratio to 1440x900,
which had been set in a previous session, without any further user interaction.
Windows resize to their correct proportions. The panel also resizes and has to
be manually stretched to fill the screen width.

Some lines from .kde/share/config/startupconfig:

# kcmrandrrc [Screen0]
kcmrandrrc_screen0_height="1024"
kcmrandrrc_screen0_reflectx="false"
kcmrandrrc_screen0_reflecty="false"
kcmrandrrc_screen0_refresh="75"
kcmrandrrc_screen0_rotation="0"
kcmrandrrc_screen0_width="1280"

None of this was put there by me.
Comment 11 Steven M. Parrish 2008-09-28 18:21:21 EDT
Ping?
Comment 12 Patrick O'Callaghan 2008-09-29 01:11:08 EDT
Now using KDE 4.1.1 and the problem appears to have gone away, i.e. when I log in the aspect ratio is correct and requires no adjustment. The .kde/share/config/startupconfig file is still there but the kcmrandrrc values are now correct, to wit:

kcmrandrrc_screen0_height="900"
kcmrandrrc_screen0_reflectx="false"
kcmrandrrc_screen0_reflecty="false"
kcmrandrrc_screen0_refresh="75"
kcmrandrrc_screen0_rotation="0"
kcmrandrrc_screen0_width="1440"

This corresponds to my monitor.

Note You need to log in before you can comment on or make changes to this bug.