Bug 443563 - FEAT: Match the new db schema of bz3.0 [#7 TABLE longdescs]
Summary: FEAT: Match the new db schema of bz3.0 [#7 TABLE longdescs]
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Ready Certification Tests
Classification: Retired
Component: web site   
(Show other bugs)
Version: 2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: XINSUN
QA Contact: Yu Shao
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: hwcert->BZ3_tracker
TreeView+ depends on / blocked
 
Reported: 2008-04-22 08:30 UTC by XINSUN
Modified: 2008-04-25 02:20 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-25 02:20:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description XINSUN 2008-04-22 08:30:50 UTC
7.Relate to TABLE longdescs need to change list below: 
    7.1 New  the field already_wrapped,comment_id,type (Not NULL) in the table
longdescs

(Maybe this place is not necessary to change our codes, because it just impacts
the insert the comments and the fields which are defined as                    
Not NULL have the default value in the longdescs table. So just mark it for
checking if it will have some more new logic from bz 3.2 with the longdescs.
comment_id etc.)

Comment 1 XINSUN 2008-04-23 17:10:59 UTC
Have not tested my above thought

Comment 2 XINSUN 2008-04-24 16:59:26 UTC
After fixed the login issue with Dave's patch, I can do the adding comments
test. It worked well in the hwcert catalog. the db records is below

+--------+--------+---------------------+-----------+---------+-----------+--------------+-----------------+------------+------+------------+
| bug_id | who    | bug_when            | work_time | thetext | isprivate |
public_in_it | already_wrapped | comment_id | type | extra_data |
+--------+--------+---------------------+-----------+---------+-----------+--------------+-----------------+------------+------+------------+
| 437538 | 215871 | 2008-04-24 09:58:59 |      0.00 | test    |         0 |    
       0 |               0 |    1640574 |    0 | NULL       |
+--------+--------+---------------------+-----------+---------+-----------+--------------+-----------------+------------+------+------------+

Maybe. hwcert catalog need to add some more particular codes with the column
"comment_id".Because the comment_id is 0 by default in catalog, while 3.2
bugzilla need the column "comment_id" to update or make private for the
comments. Is that right?


Comment 3 XINSUN 2008-04-25 02:20:20 UTC
Sorry for my carelessness, Column "Comment_id" is auto_increment. So close this
bug as not a bug.


Note You need to log in before you can comment on or make changes to this bug.