Bug 443580 - Hard disk installation fails
Hard disk installation fails
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
low Severity low
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: F9Blocker
  Show dependency treegraph
 
Reported: 2008-04-22 07:47 EDT by Fred New
Modified: 2008-12-24 07:11 EST (History)
4 users (show)

See Also:
Fixed In Version: anaconda-11.4.0.82
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-07 16:35:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda log file (8.70 KB, text/plain)
2008-04-22 11:03 EDT, Fred New
no flags Details
Anaconda log file, attempted NFS installation (11.80 KB, text/plain)
2008-04-23 04:53 EDT, Fred New
no flags Details
anaconda.log (44.31 KB, text/plain)
2008-05-05 13:45 EDT, Will Woods
no flags Details

  None (edit)
Description Fred New 2008-04-22 07:47:01 EDT
Description of problem:
I downloaded the F9-Preview DVD to my hard disk, copied vmlinuz and initrd.img
to /boot, configured Grub and rebooted my system.  Just after asking me about
Grub setup (after root and /boot files systems were formatted), Anaconda
complained that it cannot find image #1 on the hard drive.

Version-Release number of selected component (if applicable):
Whatever comes on the Fedora 9 Preview DVD.

How reproducible:
always

Steps to Reproduce:
1. Put Fedora-9-Preview-i386-DVD.iso in /home/fred/install/fedora9/  (/home is a
separate file system from the root file system.)
2. mount -o ro,loop /home/fred/install/fedora9/Fedora-9-Preview-i386-DVD.iso /mnt
3. cd /mnt/isolinux
4. cp initrd.img vmlinuz /boot (/boot is also separate from the root file system.)
5. Edit /boot/grub/grub.conf to make it possible to boot the vmlinuz just copied.
6. Reboot
  
Actual results:
The installation proceeds fine until after it formats the file /boot and root
file systems and asks for the grub configuration.  Then a window appears with
the following message:

Missing ISO 9660 Image

The installer has tried to mount image #1, but cannot find it on the hard drive.

Please copy this image to the drive and click Retry.  Click Exit to abort the
installation.

Virtual console 2 (df -h) shows the following file systems mounted:
/dev
/mnt/isodir (that contains fred/install/fedora9/Fedora-9-Preview-i386-DVD.iso)
/mnt/runtime
/mnt/sysimage
/mnt/sysimage/save (a logical volume that I don't want to format)
/mnt/sysimage/boot

-----------------
virtual console 3
-----------------
(the following copied by hand, please forgive typos):
...
10:26:30 INFO     : moving (1) to step bootloadersetup
10:26:30 INFO     : moving (1) to step bootloader
10:26:35 INFO     : moving (1) to step reposetup


-----------------
virtual console 4
-----------------
...
<4>Unable to load NLS charset utf8
<4>Unable to load NLS charset utf8
<7>ISO 9660 Extensions: RRIP_1991A
<7>SELinux: initialized (dev loop2, type iso9660), uses genfs_contexts 
<4>inode_doinit_with_dentry:  context_to_sid(unconfined_u:object_r:
user_home_t:0) returned 22 for dev=sda5 ino=3518391

-----------------
virtual console 5
-----------------
...
Running... /bin/mount -n -t proc -o defaults /dev/proc /mnt/sysimage/proc
Running... /min/mount -n -t iso9660 -o defaults,ro /dev/loop2 /mnt/cdimage
Running... /bin/mount -n -t iso9660 -o defaults,ro /dev/loop2 /mnt/cdimage
(I think I clicked Retry once, hence the duplicate last line.)

Expected results:
Successful installation (as I usually get).


Additional info:
Comment 1 Chris Lumens 2008-04-22 08:42:10 EDT
What values did you fill in to the UI when it prompted you for where to find the
installation media?  What directory and what partition?
Comment 2 Fred New 2008-04-22 09:20:50 EDT
/dev/sda5   and
fred/install/fedora9

I assume that it finds the ISO file fine prior to the "Missing ISO 9660 Image"
error message window, because it displays the usual GUI interface that I assume
isn't in the kernel nor in the initrd.img.

Here's more information that you probably don't need:   :-)

sda1 = /boot
sda2 = swap
sda3 = /
sda5 = /home
sda6 = VolGroup0

fdisk -l /dev/sda:

Disk /dev/sda: 80.0 GB 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x23152315

   Device Boot   Start     End      Blocks   Id  System
/dev/sda1   *        1      25      200781   83  Linux
/dev/sda2           26     213     1510110   82  Linux swap / Solaris
/dev/sda3          214    2646    19543072+  83  Linux
/dev/sda4         2647    9729    56894197+   5  Extended
/dev/sda5         2647    5079    19543041   83  Linux
/dev/sda6         5080    9729    37351093+  8e  Linux LVM

cat /proc/scsi/scsi
Attached devices:
Host: scsi0 Channel: 00 Id: 00 Lun: 00
  Vendor: ATA      Model: ST380021A        Rev: 3.19
  Type:   Direct-Access                    ANSI  SCSI revision: 05Host: scsi1
Channel: 00 Id: 00 Lun: 00
  Vendor: _NEC     Model: CD-RW NR-9100A   Rev: 2.12
  Type:   CD-ROM                           ANSI  SCSI revision: 05
Host: scsi1 Channel: 00 Id: 01 Lun: 00
  Vendor: _NEC     Model: CD-ROM CD-3002A  Rev: C000
  Type:   CD-ROM                           ANSI  SCSI revision: 05

lspci:
...
00:1f.1 IDE interface: Intel Corporation 82801BA IDE U100 Controller (rev 04)
...
Comment 3 Chris Lumens 2008-04-22 09:33:22 EDT
Okay, one more thing.  Can you run it all the way until it displays the error
message, then jump over to tty2, grab /tmp/anaconda.log, and attach it to this
report?  Thanks.
Comment 4 Fred New 2008-04-22 09:59:44 EDT
Hmm, is there some magic way of bringing up the network so I can copy this file
somewhere?  Or some other way to get this log off my broken system?
Comment 5 Fred New 2008-04-22 10:33:33 EDT
Never mind.  I've saved the log in my /save file system and I'm doing a network
installation of F8.  I should have anaconda.log for you shortly.
Comment 6 Fred New 2008-04-22 11:03:01 EDT
Created attachment 303325 [details]
Anaconda log file
Comment 7 Fred New 2008-04-23 04:53:41 EDT
Created attachment 303458 [details]
Anaconda log file, attempted NFS installation

I attempted to install Fedora 9 Preview Release using PXE, NFS and kickstart. 
The installation failed with the same message window as the hard disk
installation.  I used a kickstart file from Fedora 8, but I don't think that
should matter.
Comment 8 Chris Lumens 2008-04-23 12:17:35 EDT
I think this is the same base cause as the related NFSISO bug (only seeing it on
DVDs, not CDs) so I am going to go ahead and close this one as a dupe.  We can
always reopen it later if that turns out to not be the case.

*** This bug has been marked as a duplicate of 443291 ***
Comment 9 David Timms 2008-04-26 10:30:31 EDT
Found the same messages, failure to upgrade an F8 install [another who doesn't
bother burning the dvd, but uses the hard disk method and one of the other
booting methods {pxeboot, rescue=netboot=boot.iso}].

Chris: since there won't isn't expected be another public dvd iso before 9GA,
this would need to be tested internally to ensure it is solved, cheers.
Comment 10 Will Woods 2008-05-05 13:41:48 EDT
HDISO installs aren't working with current F9 candidates. As far as I can tell
the symptoms match this bug, so I'm reopening it.

Note that NFSISO installs (bug 443291) *do* work.
Comment 11 Will Woods 2008-05-05 13:45:26 EDT
Created attachment 304541 [details]
anaconda.log

anaconda.log of failed install attempt. F9 image is in sdb1:/F9/i386/
Comment 12 Warren Togami 2008-05-05 16:16:23 EDT
My test both booted from and installing from Jesse's 20080503 DVD i686 ISO
copied onto an ext3 formatted USB disk succeeded without an error.
Comment 13 Will Woods 2008-05-05 17:20:50 EDT
Oh ho. I moved the iso to the root directory of the drive and left the
'directory' field blank, and now it works fine.

I'm guessing it's some kind of subdirectory / path search problem. At least
there's a workaround.
Comment 14 Chris Lumens 2008-05-06 15:52:20 EDT
This should be fixed in the next build of anaconda both for head and for f9.
Comment 15 Will Woods 2008-05-07 16:35:43 EDT
Confirmed fixed.
Comment 16 mraufer 2008-12-23 19:58:16 EST
I'm experiencing the exact same problem and error messages trying to install F10 from harddisk. I have copied the contents of the ISO DVD image to a separate partition (sdb1) and want to install F10 onto the remainder of sdb (sda1 holds Win98 and I have no DVD drive).

I changed "ALL" to "1" in .discinfo but to no avail. I have no clue as to what ISO file the installer wants to mount at reposetup, nor what SELinux has initialized on /dev/loop2 that fails to be mounted.

I have tried the install via NFS and FTP. While that gets past the reposetup stage, network installation fails later during package installation due to time-out or system hang (it's an old Pentium3 system, 256MB RAM).

THe hard disk install was my last hope - please help to fix this.

Thanks.
Comment 17 Fred New 2008-12-24 07:11:13 EST
Mraufer: The hard disk installation for F10 needs the .iso file, not the contents.  According to
http://docs.fedoraproject.org/install-guide/f10/en_US/sn-installing-from-harddrive.html,
you only need to copy the contents of the images/ directory to your hard disk, to the same location where the .iso file is.

Note You need to log in before you can comment on or make changes to this bug.