Bug 443602 - haldaemon doesn't start (was: no sound with xine)
haldaemon doesn't start (was: no sound with xine)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
9
All Linux
low Severity urgent
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-22 10:21 EDT by Adrin Jalali
Modified: 2013-03-05 22:55 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-09 09:13:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
catalog.cache (23.89 KB, text/plain)
2008-04-23 03:35 EDT, Adrin Jalali
no flags Details
dmesg output (31.08 KB, text/plain)
2008-04-24 00:51 EDT, Adrin Jalali
no flags Details
stderr from haldaemon script, with an exec 2>| logfile added (1.89 KB, text/plain)
2008-05-19 15:01 EDT, Alec Leamas
no flags Details

  None (edit)
Description Adrin Jalali 2008-04-22 10:21:57 EDT
when I try to use xine even with kaffeine or with amarok, this error occures :

Loading of player part 'XinePart' failed.
All Audio Drivers failed to initialize!

version:
xine-lib-extras-1.1.11.1-2.fc9.i386
xine-lib-extras-nonfree-1.1.11.1-1.lvn9.i386
xine-lib-1.1.11.1-2.fc9.i386
totem-xine-2.23.1-1.fc9.i386


# dmesg | grep sound
ALSA sound/pci/hda/hda_intel.c:1810: chipset global capabilities = 0x4401
ALSA sound/pci/hda/hda_intel.c:749: codec_mask = 0x3
ALSA sound/pci/hda/hda_codec.c:2236: hda_codec: model 'dell-m25' is selected for
config 1028:1bd (Dell Inspiron E1505n)
ALSA sound/pci/hda/patch_sigmatel.c:1712: hda_codec: pin nid 08 pin config 40c003fa
ALSA sound/pci/hda/patch_sigmatel.c:1712: hda_codec: pin nid 09 pin config 01441340
ALSA sound/pci/hda/hda_intel.c:596: hda_intel: azx_get_response timeout,
switching to polling mode: last cmd=0x00df1c00
ALSA sound/pci/hda/patch_sigmatel.c:1712: hda_codec: pin nid 0d pin config 0421121f
ALSA sound/pci/hda/patch_sigmatel.c:1712: hda_codec: pin nid 0e pin config 90170310
ALSA sound/pci/hda/patch_sigmatel.c:1712: hda_codec: pin nid 0f pin config 408003fb
ALSA sound/pci/hda/patch_sigmatel.c:1712: hda_codec: pin nid 10 pin config 04a11020
ALSA sound/pci/hda/patch_sigmatel.c:1712: hda_codec: pin nid 11 pin config 401003fc
ALSA sound/pci/hda/patch_sigmatel.c:1712: hda_codec: pin nid 12 pin config 403003fd
ALSA sound/pci/hda/hda_codec.c:2857: autoconfig: line_outs=1 (0xe/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:2861:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:2865:    hp_outs=1 (0xd/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:2866:    mono: mono_out=0x0
ALSA sound/pci/hda/hda_codec.c:2874:    inputs: mic=0x10, fmic=0x0, line=0x0,
fline=0x0, cd=0x0, aux=0x0


# /sbin/lspci
00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT
Express Memory Controller Hub (rev 03)
00:01.0 PCI bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT
Express PCI Express Root Port (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition
Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1
(rev 01)
00:1c.3 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 4
(rev 01)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI
Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge
(rev 01)
00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA IDE
Controller (rev 01)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 01)
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility X1400
03:00.0 Ethernet controller: Broadcom Corporation BCM4401-B0 100Base-TX (rev 02)
03:01.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller
03:01.1 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host
Adapter (rev 19)
03:01.2 System peripheral: Ricoh Co Ltd R5C843 MMC Host Controller (rev 0a)
03:01.3 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter
(rev 05)
03:01.4 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev ff)
0b:00.0 Network controller: Broadcom Corporation BCM94311MCG wlan mini-PCI (rev 01)
Comment 1 Rex Dieter 2008-04-22 10:42:15 EDT
works fine here (using kaffeine and amarok).  I'll try out totem-xine.
Comment 2 Adrin Jalali 2008-04-23 03:33:47 EDT
I upgraded from fedora 9 betta to last rawhide and this happened.
I'll attache a maybe related file and this is the lsmod output.

# /sbin/lsmod
Module                  Size  Used by
vfat                   13056  0 
fat                    42784  1 vfat
usb_storage            76296  0 
cdc_acm                16260  0 
rfcomm                 34576  0 
l2cap                  22272  3 rfcomm
sunrpc                151412  3 
ipt_REJECT              6784  2 
nf_conntrack_ipv4      11396  8 
iptable_filter          6528  1 
ip_tables              13840  1 iptable_filter
nf_conntrack_netbios_ns     6144  0 
ip6t_REJECT             7552  2 
xt_tcpudp               6656  14 
nf_conntrack_ipv6      15864  8 
xt_state                5888  16 
nf_conntrack           49748  4
nf_conntrack_ipv4,nf_conntrack_netbios_ns,nf_conntrack_ipv6,xt_state
ip6table_filter         6400  1 
ip6_tables             14736  1 ip6table_filter
x_tables               15236  6
ipt_REJECT,ip_tables,ip6t_REJECT,xt_tcpudp,xt_state,ip6_tables
cpufreq_ondemand       10124  1 
acpi_cpufreq           11532  1 
fuse                   41116  4 
dm_mirror              26116  0 
dm_multipath           18056  0 
dm_mod                 49236  2 dm_mirror,dm_multipath
radeon                116996  2 
drm                   145508  3 radeon
ipv6                  221660  14 ip6t_REJECT,nf_conntrack_ipv6
snd_hda_intel         330144  1 
snd_seq_dummy           6660  0 
arc4                    5760  2 
snd_seq_oss            30364  0 
ecb                     6528  2 
crypto_blkcipher       17924  1 ecb
b43                   123168  0 
rfkill                  9108  1 b43
snd_seq_midi_event      9600  1 snd_seq_oss
mac80211              184928  1 b43
firewire_ohci          21636  0 
snd_seq                48448  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device         10124  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            42496  0 
snd_mixer_oss          16768  2 snd_pcm_oss
snd_pcm                67076  2 snd_hda_intel,snd_pcm_oss
firewire_core          34336  1 firewire_ohci
snd_timer              21640  2 snd_seq,snd_pcm
cfg80211               24712  1 mac80211
input_polldev           7176  1 b43
sdhci                  16908  0 
snd_page_alloc         11400  2 snd_hda_intel,snd_pcm
wmi                     9640  0 
mmc_core               40604  1 sdhci
hci_usb                16284  0 
snd_hwdep              10500  1 snd_hda_intel
video                  20368  0 
ricoh_mmc               7552  0 
crc_itu_t               5760  1 firewire_core
b44                    25488  0 
mii                     8192  1 b44
output                  6656  1 video
snd                    48312  10
snd_hda_intel,snd_seq_dummy,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_hwdep
bluetooth              47588  3 rfcomm,l2cap,hci_usb
button                 10000  0 
iTCO_wdt               13476  0 
pcspkr                  6272  0 
ac                      8068  0 
joydev                 12608  0 
iTCO_vendor_support     6916  1 iTCO_wdt
ssb                    34052  2 b43,b44
i2c_i801               11920  0 
battery                14084  0 
dcdbas                 10272  0 
i2c_core               20628  2 drm,i2c_i801
soundcore               9288  2 snd
sr_mod                 17064  0 
cdrom                  32796  1 sr_mod
sg                     31028  0 
ata_generic             8964  0 
pata_acpi               8192  0 
ata_piix               19972  5 
libata                126432  3 ata_generic,pata_acpi,ata_piix
sd_mod                 25624  6 
scsi_mod              120820  5 usb_storage,sr_mod,sg,libata,sd_mod
ext3                  108424  3 
jbd                    40852  1 ext3
mbcache                10116  1 ext3
uhci_hcd               22928  0 
ohci_hcd               22276  0 
ehci_hcd               32268  0 


Comment 3 Adrin Jalali 2008-04-23 03:35:46 EDT
Created attachment 303443 [details]
catalog.cache
Comment 4 Adrin Jalali 2008-04-23 07:36:19 EDT
Finally I've found it :D the problem was with haldaemon. it was shut down. While
starting, start of haldaemon fails and I should start it manually. So how can I
report this ?
Comment 5 Rex Dieter 2008-04-23 09:49:34 EDT
Reassigning to hal, hopefully those kind folks can help sort out what's going wrong.
Comment 6 Matthias Clasen 2008-04-23 13:01:18 EDT
Adrin, can you show us the output you get when starting hal fails ?
Comment 7 Adrin Jalali 2008-04-24 00:51:35 EDT
Created attachment 303574 [details]
dmesg output

ok, I'd like to, but when I start the service after login, no problem exists,
and haldeamon starts and after that, my xine can play audio. But I can attach
the dmesg output for you. I think it's the least.
Comment 8 Adrin Jalali 2008-04-24 00:56:17 EDT
Also my avahi daemon has the same problem and I should start it manually after
logon.
Comment 9 Anton Guda 2008-04-25 06:02:48 EDT
This bug I detected after glibc update to 2.8.

hald don't show any specific error message (exept 'Failed') at system
startup, so I don't know how to debug this condition.
After system startup hald starts without errors.
Comment 10 Bug Zapper 2008-05-14 05:56:48 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Alec Leamas 2008-05-19 15:00:17 EDT
Confirmed, I have the same problem. Attaching log from tweaked haldaemon script.
Comment 12 Alec Leamas 2008-05-19 15:01:58 EDT
Created attachment 305996 [details]
stderr from haldaemon script, with an exec 2>| logfile added
Comment 13 Tom Gutwin 2008-05-20 16:16:02 EDT
What are the start priorities in the rc.d dirs?

Does bug sound like whats going on...
https://bugzilla.redhat.com/show_bug.cgi?id=444410

Comment 14 Alec Leamas 2008-05-21 05:50:01 EDT
Indeed, this recipe from bug 444410 works for me (tm):

chkconfig network resetpriorities 
chkconfig messagebus resetpriorities 
chkconfig haldaemon resetpriorities 
Comment 15 Alec Leamas 2008-05-22 14:58:34 EDT
Actually, the recipe solved the hald problem. However, after doing an update
earlier today the network startup fails. I have a bridge setup, this might
possibly be part of the problem.

To boot the system, I now need the following in rc.local:

service network restart
brctl addif br0 vbox5

All this occurred automagically (without any rc.local stuff) until yesterday,
governed by the scripts in /etc/sysconfig/network-scripts. Seems like a mess,
this ;-)
Comment 16 Scott Glaser 2009-04-07 20:56:11 EDT
Adrin,
Are you still running Fedora 9, or have you upgraded to 10 or Rawhide? In
either case, can you let us know whether the issue is still happening, and give
the current version of the HAL packages you're using?



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 17 Adrin Jalali 2009-04-09 05:36:52 EDT
I'm using Fedora 10 using 

hal-cups-utils-0.6.19-1.fc10.x86_64
hal-libs-0.5.12-14.20081027git.fc10.x86_64
hal-0.5.12-14.20081027git.fc10.x86_64
hal-info-20090202-1.fc10.noarch

and the problem was solved a few days after reporting this problem. As I remember, that was because of wrong order of services on start up. And that was the reason when I started it manually, it works fine.

I think the bug should be closed ;) :)

Regards.
Comment 18 Scott Glaser 2009-04-09 09:13:28 EDT
Thank you for your bug report. We are closing this bug based on the users latest comment.  If these symptoms should return please ensure that your utilizing the latest version of the component and then file a new bug report against that version.

CLOSED: NOTABUG

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.