Bug 443608 - Thinkpad Trackpoint middle button scrolling not working
Summary: Thinkpad Trackpoint middle button scrolling not working
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-mouse
Version: 9
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Peter Hutterer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-04-22 14:56 UTC by Derek Cramer
Modified: 2008-07-18 06:11 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-18 06:11:54 UTC


Attachments (Terms of Use)
Xorg.0.log (25.66 KB, text/plain)
2008-04-22 14:56 UTC, Derek Cramer
no flags Details
Xorg.conf. These settings work as expected in F8. (1.19 KB, text/plain)
2008-04-22 14:59 UTC, Derek Cramer
no flags Details

Description Derek Cramer 2008-04-22 14:56:53 UTC
Description of problem:
Trackpoint middle button scrolling does not work in rawhide / F9

Version-Release number of selected component (if applicable):
xorg-x11-drv-mouse-1.3.0-1.fc9.i386

How reproducible:
Consistently every session.

Steps to Reproduce:
1. Enable middle button scrolling in xorg.conf (as per
http://www.thinkwiki.org/wiki/How_to_configure_the_TrackPoint#Using_the_X_server_.28kernel_2.6.11.2B.29)
2. Try to scroll up or down in any window (gnome-terminal, firefox, gedit etc.)
This works perfectly in Fedora 8 on the same machine and the same xorg.conf.
3. Profit ??
  
Actual results:
Holding middle mouse button and moving trackpoint just moves the pointer as
though the middle button wasn't pressed.

Expected results:
Window should scroll up or down.

Additional info:
Lenovo Thinkpad T60 (1951-CZ1). UltraNav disabled in BIOS - just using
Trackpoint. Can also test on a T40 and T41 if required, but haven't done so yet.
X.0.log and xorg.conf attached.

Comment 1 Derek Cramer 2008-04-22 14:56:53 UTC
Created attachment 303322 [details]
Xorg.0.log

Comment 2 Derek Cramer 2008-04-22 14:59:14 UTC
Created attachment 303323 [details]
Xorg.conf. These settings work as expected in F8.

Comment 3 Bug Zapper 2008-05-14 09:56:55 UTC
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 4 Ventsislav Genchev 2008-05-16 18:27:51 UTC
I can also confirm the problem on my R51.
It is present on xorg-x11-drv-mouse-1.3.0-2.fc9

Comment 5 Marcin Zablocki 2008-05-19 21:16:21 UTC
I can also confirm on T42p. 

Comment 6 Stepan Lendak 2008-05-20 07:49:59 UTC
solution is here (not tested):

http://vbraun.name/cms/node/7

Comment 7 Derek Cramer 2008-05-20 12:59:33 UTC
> solution is here (not tested):
> 
> http://vbraun.name/cms/node/7

(In reply to comment #6)
Volker's solution (above link) works for me. Not sure whether it is a good
permanent solution though. I had never heard of the evdev driver before. Are
there any other potentially unwanted side effects of disabling AutoAddDevices?
My external USB mouse still works as expected, so I'm happy enough. Should X
respect the mouse driver if specified in the xorg.conf, or is evdev supposed to
take over?


Comment 8 Ventsislav Genchev 2008-05-21 16:20:02 UTC
Personally, I have only the following lines on top of the xorg.conf file in
order to get it all working again:

Section "ServerFlags"
        Option "AutoAddDevices" "false"
EndSection


No need of the evdev driver.

Comment 9 Peter Hutterer 2008-07-18 06:11:54 UTC
In F9, input devices are hotplugged with the evdev driver. The list of devices
is provided by HAL, and any device using evdev will not send to /dev/input/mice.
If a InputDevice is configured for /dev/input/mice, it won't generate any event
if all mice are hotplugged through HAL. This usually looks like the
configuration is ignored or lost.

The two options to fix this is:
- Add Option "AutoAddDevices" "off" to the ServerLayout. This disables input
device hotplugging alltogether and prevents evdev from taking over.
- Change the InputDevice section to use evdev as driver and specify the device
file as /dev/input/by-id/... or /dev/input/by-path/... /dev/input/event0 is
valid too, but those numbers may change on reboot.
If you choose this option, you may have to specify multiple InputDevice sections
since evdev does not have an equivalent to /dev/input/mice.

Beware that some option that are supported in the mouse driver may not be
available in the evdev driver. If so, you can file a feature request with
upstream at http://bugs.freedesktop.org/show_bug.cgi?id=16699. 

Closing as NOTABUG since it was caused by a configuration problem.


Note You need to log in before you can comment on or make changes to this bug.