Bug 44361 - genericups doesn't open device O_NONBLOCK
Summary: genericups doesn't open device O_NONBLOCK
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: nut   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-13 01:02 UTC by j. alan eldridge
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-13 01:03:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
open() non-blocking in open_serial_simple() (374 bytes, patch)
2001-06-13 01:03 UTC, j. alan eldridge
no flags Details | Diff

Description j. alan eldridge 2001-06-13 01:02:18 UTC
Description of Problem:

The genericups driver app is for "Stupid" UPSs that use "simple 
signalling". They don't transmit data, they just raise/lower control 
signals.

Opening the file (e.g., ttyS1) in blocking mode will block (and fail with 
a timeout) because the right signals aren't present.

The attached patch is against 0.45.0 but should work for 0.44.x as well.

Comment 1 j. alan eldridge 2001-06-13 01:03:09 UTC
Created attachment 20925 [details]
open() non-blocking in open_serial_simple()

Comment 2 Ngo Than 2001-06-13 08:52:53 UTC
The new nut-0.45-1 in rawhide has this patch. Thanks



Note You need to log in before you can comment on or make changes to this bug.