Bug 44362 - Confusing time specifications
Summary: Confusing time specifications
Status: CLOSED DUPLICATE of bug 79568
Alias: None
Product: Bugzilla
Classification: Community
Component: Bugzilla General   
(Show other bugs)
Version: 2.1r
Hardware: i386
OS: Linux
medium
medium vote
Target Milestone: ---
Assignee: David Lawrence
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-13 01:03 UTC by Enrico Scholz
Modified: 2007-04-18 16:33 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:48:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (21.26 KB, image/png)
2001-06-18 16:42 UTC, Enrico Scholz
no flags Details

Description Enrico Scholz 2001-06-13 01:03:02 UTC
When giving some details (e.g. an attachment) immediately after entering a
bug, the times shown in both bugs are differing in 12 hours. E.g. look bug
#44360: bug was reported at 001-06-12 08:45:04, the attachment I have made
some seconds later is labeled with 2001-06-12 20:45:46.

This is very confusing...



I suggest to show all times in GMT -- most people know the difference of
their timezone to GMT, but only a few to Red Hat's localtime (EDT??)...

The timezone should be shown explicitly also.


And btw: please adjust the time of gribble.redhat.com (an NTP client would
be perhaps a good idea) -- it seems to differ around 5 minutes from the
official time. ;)

Comment 1 David Lawrence 2001-06-18 16:06:33 UTC
Viewing bug 44360, the date shows up next to the attachments as 2001-06-12
08:45:46 for me.

Comment 2 Enrico Scholz 2001-06-18 16:41:24 UTC
Will attach an image showing how my browser is displaying it (tried it both with
`de_DE' and `en' as used language). 

Perhaps this strange AM/PM presentation of time in a few locales is responsible?

Comment 3 Enrico Scholz 2001-06-18 16:42:06 UTC
Created attachment 21250 [details]
screenshot

Comment 4 Christian Rose 2002-10-25 18:41:08 UTC
I have to confirm this -- I never ever knew what time "EDT" is or how it relates
to my time zone, but what I *do* know is the difference of my time zone to UTC.

I suggest bugzilla uses UTC times throughout and also labels time stamps with "UTC".

Comment 5 David Lawrence 2002-10-25 19:04:53 UTC
http://bugzilla.redhat.com/rh-bugzilla-beta3/show_bug.cgi?id=44362

Please see if this is acceptable concerning the date presentation


Comment 6 Enrico Scholz 2002-10-25 19:18:16 UTC
What it the meaning of the trailing '-04'? And are you sure that the time is
calculated correctly? E.g.

http://bugzilla.redhat.com/rh-bugzilla-beta3/show_bug.cgi?id=76578

says that the bug was entered at '2002-10-25 13:22:57.553146-04 GMT' but it was
entered this afternoon (+0200 localtime). 

Showing the microseconds seems to be a little bit too much information and
confuses at this place IMO.

Comment 7 Christian Rose 2002-10-25 19:46:43 UTC
"2001-06-18 12:42:06-04 GMT"

Showing seconds seem to much information, I think. But perhaps there are
situations where it is needed, but I don't think that's true for most cases.

Second, I still strongly propose that you should use times in the UTC time zone.
That way no time zone differences have to be specified, and different daylight
savings times etc. won't cause trouble. This is after all what UTC should be
used for. So instead of the above time stamp, it should read "2001-06-18
08:42:06 UTC" instead. No fuzz, no mess.

Third, please refrain from using the acronym "GMT". It was not only obsoleted
already in 1972, it is also ambigious as it can be different from UTC. See the
links http://www.cl.cam.ac.uk/~mgk25/iso-time.html and
http://www.apparent-wind.com/gmt-explained.html for more information about that.

Comment 8 Aleksey Nogin 2002-12-13 19:42:19 UTC
Th new Bugzilla seems to be using a different time format. Is still confuses the
time zones though - see bug 79568

*** This bug has been marked as a duplicate of 79568 ***

Comment 9 Red Hat Bugzilla 2006-02-21 18:48:01 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.