Bug 443632 - iwlwifi less functional than in Fedora8
iwlwifi less functional than in Fedora8
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-22 12:13 EDT by Clemens Eisserer
Modified: 2008-08-19 14:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-19 14:46:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Dmesg and iwconfig output (26.17 KB, text/plain)
2008-05-08 07:50 EDT, Clemens Eisserer
no flags Details

  None (edit)
Description Clemens Eisserer 2008-04-22 12:13:29 EDT
Description of problem:
My hardware has several troubles using the iwlwifi driver, it only worked using
in a few networks in Fedora8 - therefor I used ipw3945. (I have a 3945 wireless
chipset).

On Fedora9-Rawhide I am not able to connect any network. The driver seems to
assicoate with the AP correctly, but not a single byte is transmitted.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Matthias Saou 2008-04-24 07:00:39 EDT
Reassigning to the kernel component, as this is more a driver issue than a
firmware packaging issue.
Comment 2 John W. Linville 2008-04-24 09:05:43 EDT
Are you using iwl3945?  Or ipw3945?
Comment 3 Clemens Eisserer 2008-04-24 11:55:39 EDT
I am experiencing the problems when using iwl3945, ipw3945 works (almost) perfectly.
Comment 4 John W. Linville 2008-04-24 13:08:53 EDT
OK...so are you comparing iwl3945 (apples) in F9 to ipw3945 (oranges) on F8?  
Or are you comparing apples to apples?  Sorry, have to clarify...
Comment 5 Clemens Eisserer 2008-04-24 13:24:56 EDT
Sorry for beeing so confusing:

Fedora8-ipw3945: No Problems
Fedora8-iwl3945: Some problems, only some networks work. Problems with
authetication on some, sometimes problems with Access point association.
Fedora9-iwl3945: Not working at all.
Comment 6 John W. Linville 2008-04-29 16:26:57 EDT
Clemens, can you specify exact kernel versions you are using with iwl3945 on 
F8 and F9?
Comment 7 Clemens Eisserer 2008-05-08 07:48:50 EDT
It was Fedora9-Beta, with the original kernel and later updated (arround 20th of
april), and it never worked.

On Fedora8 I had several 2.6.23 kernels which did not work, and I've just
updated to 2.6.24.5-85.fc8 which also does not work.

I use the following commands to set-up my wireless network:
/sbin/ifconfig wlan0 up;
slebep 2;
/sssbin/dhclient;
 
I attached the dmesg log and the /sbin/iwconfig output.


Thanks for your investigation, lg Clemens

PS: By the way Fedora9-Beta was *extremly* buggy. I don't know wether its a good
idea to release stuff as Beta which which is not in a state where external
tetsing is even required. It just frustrates users which really would like in
helping catch bugs.
Comment 8 Clemens Eisserer 2008-05-08 07:50:05 EDT
Created attachment 304850 [details]
Dmesg and iwconfig output
Comment 9 John W. Linville 2008-05-08 11:21:38 EDT
I didn't see you mention a 'iwconfig wlan0 essid HippyNet'.  Did you do this 
before the 'ifconfig wlan0 up'?

Setting the SSID needs to be the last part of the wireless config before 
running dhclient.  So, something like the following:

   ifconfig wlan0 up
   iwconfig wlan0 key <KEY> # replace <KEY> with the appropriate value
   iwconfig wlan0 essid HippyNet
   sleep 2 # this may or may not be necessary
   dhclient wlan0

Does using that order change the situation?
Comment 10 Clemens Eisserer 2008-05-08 14:59:22 EDT
oh sorry, I somehow messed the commands up I wrote above.

In fact I ussed exactly the same commands as you did, and it did not work:
/sbin/ifconfig wlan0 up;
sleep 2;
/sbin/iwconfig wlan0 essid HippyNet key 9dacc2d8d15e36359102274429;
sleep 2;
/sbin/dhclient;

And it does not work, it does not assicoate with the AP at all :-/

Thanks for your patience, lg Clemens
Comment 11 Bug Zapper 2008-05-14 05:57:15 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 12 John W. Linville 2008-05-20 14:58:36 EDT
Can you recreate this issue with the test kernels here?

   http://koji.fedoraproject.org/koji/buildinfo?buildID=49743
Comment 13 Clemens Eisserer 2008-05-22 07:00:28 EDT
Sure, I'll test it.

It seems the connecting-issues are AP related. I can connect to an WRT54GL, and
also at univesity I can connect to the cisco-APs there but connection was not
stable at university. Once broken, I was not able to re-connect without reboot.

At home I have an SMC AP, which works for:
- Nokia 770
- Nokia N800
- Medion laptop with atmel at7650x pcmicia card (11mb)
- My 3945 laptop with the ipw3945 driver
Comment 14 Clemens Eisserer 2008-05-22 07:35:40 EDT
With the new kernel its still the same.

With manual settings with iwconfig, it refuses to assicoate with the AP.
The NetworkManager-Applet does not detect the network at all.

Both proceedings woth with ipw3945 or the Atmel-Chip.

Clemens
Comment 15 John W. Linville 2008-05-22 07:51:37 EDT
Do you have a line like this in /etc/modprobe.conf?

   options iwl3945 disable_hw_scan=1

If so, can you remove it?  If not, can you add it?  Does adding/removing it 
change the situation?
Comment 16 Clemens Eisserer 2008-05-22 15:29:38 EDT
I don't have an /etc/modprobe.conf (at least when accessing my Fedora9 partition
while running Fedora)

Thanks, Clemens
Comment 17 Clemens Eisserer 2008-06-04 06:57:17 EDT
Is there more information I can provide which could be useful?

It would be great to get this fixed, for now I am stuck with a 2.6.20 kernel
(originally compiled under/for Fedora Core 6) which complicates updates to Fedora9.

I don't believe this is distribution-specific but rather a bug in the drivers,
however ... it would be great if it could be resolved, maybe together with Intel?

Thanks, Clemens
Comment 18 John W. Linville 2008-06-04 09:38:36 EDT
You really haven't given me anything to go on.  Among other things, it is
extremely difficult to believe that you don't have an /etc/modprobe.conf file as
you stated in comment 15 -- I don't think I've seen a single box that didn't
have one.  This suggests that your installation has been damaged somewhere along
the way.  The best approach may be a completely clean installation of F9.

If you don't want to do that, you might try disabling NetworkManager:

   service NetworkManager stop

Then bring-up the device:

   ifconfig wlan0 up

Then manually configure it for your AP (assuming it is unencrypted or using WEP):

   iwlist wlan0 scan
   iwconfig wlan0 key <WEP key>
   iwconfig wlan0 essid <SSID>

After that, please attach the output of running iwconfig and ifconfig as well as
the output of dmesg.

If you are not using WEP or unencrypted APs, please tell me about your network's
encryption (not keys, just protocols).

Also, whether or not you have an /etc/modprobe.conf now please implement my
request from comment 15, reboot, and retry the steps above.  Thanks!
Comment 19 John W. Linville 2008-08-19 14:46:07 EDT
Closed due to lack of response...

Note You need to log in before you can comment on or make changes to this bug.