Bug 443633 - No network configuration dialog in stage2 installer when doing kickstart.
Summary: No network configuration dialog in stage2 installer when doing kickstart.
Keywords:
Status: CLOSED DUPLICATE of bug 401531
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda
Version: 5.1
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Anaconda Maintenance Team
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-04-22 16:14 UTC by Ray Van Dolson
Modified: 2008-04-22 19:40 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-04-22 19:40:24 UTC


Attachments (Terms of Use)
This screen no longer shows up during a kickstart installation. (83.51 KB, image/png)
2008-04-22 16:14 UTC, Ray Van Dolson
no flags Details
This patch to anaconda resolves the issue for me. (571 bytes, patch)
2008-04-22 16:16 UTC, Ray Van Dolson
no flags Details | Diff
This updates.img file incorporates the patch above and solves the issue for me. (1.41 MB, application/octet-stream)
2008-04-22 16:16 UTC, Ray Van Dolson
no flags Details

Description Ray Van Dolson 2008-04-22 16:14:29 UTC
Description of problem:
The stage 2 installer (GUI or text) does not prompt for network information when
kickstarting.


Version-Release number of selected component (if applicable):
Whatever comes with RHEL 5.1

How reproducible:
Always

Steps to Reproduce:
1. Write kickstart configuration.
2. Boot to installer, obtain IP via DHCP in stage1, continue to GUI installer.
3. No network configuration screen is presented.
  
Actual results:
No network configuration screen is presented.

Expected results:
Network screen should be presented regardless as was behavior in RHEL4 anaconda.

Additional info:
I will attach a screenshot of the network configuration screen I would like to
see.  Please do not confuse this for #401531.  I am not trying to configure IP
information *before* the GUI installer begins, but during.

Comment 1 Ray Van Dolson 2008-04-22 16:14:29 UTC
Created attachment 303333 [details]
This screen no longer shows up during a kickstart installation.

Comment 2 Ray Van Dolson 2008-04-22 16:16:13 UTC
Created attachment 303335 [details]
This patch to anaconda resolves the issue for me.

Comment 3 Ray Van Dolson 2008-04-22 16:16:40 UTC
Created attachment 303336 [details]
This updates.img file incorporates the patch above and solves the issue for me.

Comment 4 Ray Van Dolson 2008-04-22 16:21:57 UTC
Actually, apparently this is being addressed in #401531.  Please close this out.

Comment 5 Jeremy Katz 2008-04-22 19:40:24 UTC

*** This bug has been marked as a duplicate of 401531 ***


Note You need to log in before you can comment on or make changes to this bug.