Bug 443644 - PulseAudio Volume Control crashes on startup
PulseAudio Volume Control crashes on startup
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
rawhide
i686 Linux
low Severity low
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-22 13:19 EDT by Jay Fenlason
Modified: 2014-08-31 19:28 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-24 21:35:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Bug report from reporting tool. (245.92 KB, text/plain)
2008-04-22 13:19 EDT, Jay Fenlason
no flags Details

  None (edit)
Description Jay Fenlason 2008-04-22 13:19:34 EDT
Description of problem:
I go to Applications->Sound & Video -> Pulse Audio Volume Control.  It pops up 
a window.  Then the bug reporting tool comes up.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Attempt to start the volume control app
2.
3.
  
Actual results:
Bug reporting tool starts

Expected results:
I should be able to adjust volume, etc.


Additional info:
The machine is here in Westford if you want to poke at it.
Comment 1 Jay Fenlason 2008-04-22 13:19:35 EDT
Created attachment 303343 [details]
Bug report from reporting tool.
Comment 2 Matthias Clasen 2008-04-22 14:13:03 EDT
can you run it under gdb and get a more useful stacktrace ?
is pulseaudio running when this happens ?
Comment 3 Jay Fenlason 2008-04-22 15:22:49 EDT
After much debuginfo-install-ing, I got:
(gdb) bt
#0  0x009e56b3 in strlen () from /lib/libc.so.6
#1  0x04fcc398 in Glib::ustring::operator= (this=Could not find the frame base 
for "Glib::ustring::operator=(char const*)".
)
    at /usr/include/c++/4.3.0/bits/char_traits.h:262
#2  0x08050e3d in server_info_cb (i=0x0, userdata=0x8474390)
    at pavucontrol.cc:1046
#3  0x0083b841 in context_get_server_info_callback (pd=<value optimized out>, 
    command=<value optimized out>, tag=Could not find the frame base 
for "context_get_server_info_callback".
) at pulse/introspect.c:117
#4  0x008611e5 in run_action (pd=<value optimized out>, 
    r=<value optimized out>, command=<value optimized out>, 
    ts=<value optimized out>) at pulsecore/pdispatch.c:185
#5  0x00861e08 in pa_pdispatch_run (pd=<value optimized out>, 
    packet=<value optimized out>, creds=<value optimized out>, userdata=Could 
not find the frame base for "pa_pdispatch_run".
)
    at pulsecore/pdispatch.c:236
#6  0x00833abf in pstream_packet_callback (p=<value optimized out>, 
    packet=<value optimized out>, creds=<value optimized out>, 
    userdata=<value optimized out>) at pulse/context.c:306
#7  0x00863ffb in do_something (p=<value optimized out>)
    at pulsecore/pstream.c:818
#8  0x00864ce9 in io_callback (io=<value optimized out>, 
    userdata=<value optimized out>) at pulsecore/pstream.c:215
#9  0x00856a78 in callback (m=<value optimized out>, e=<value optimized out>, 
    fd=<value optimized out>, f=<value optimized out>, 
    userdata=<value optimized out>) at pulsecore/iochannel.c:121
---Type <return> to continue, or q <return> to quit---
#10 0x00383399 in dispatch_func (source=<value optimized out>, callback=Could 
not find the frame base for "dispatch_func".
)
    at pulse/glib-mainloop.c:587
#11 0x00b93098 in IA__g_main_context_dispatch (context=<value optimized out>)
    at gmain.c:2009
#12 0x00b96743 in g_main_context_iterate (context=<value optimized out>, 
    block=<value optimized out>, dispatch=<value optimized out>, self=Could 
not find the frame base for "g_main_context_iterate".
)
    at gmain.c:2642
#13 0x00b96c62 in IA__g_main_loop_run (loop=<value optimized out>)
    at gmain.c:2850
#14 0x04cba90d in IA__gtk_main () at gtkmain.c:1163
#15 0x05f0acc7 in Gtk::Main::run_impl (this=Could not find the frame base 
for "Gtk::Main::run_impl()".
) at main.cc:534
#16 0x05f0adee in Gtk::Main::run (window=<value optimized out>) at main.cc:488
#17 0x08055a50 in main (argc=134584400, argv=0xad0000) at pavucontrol.cc:1212

I have no idea if pulseaudio is running or not.  How do I tell?
Comment 4 Matthias Clasen 2008-04-23 00:48:17 EDT
ps ax | grep pulseaudio 

should tell you
Comment 5 Jay Fenlason 2008-04-23 12:04:24 EDT
ps ax | egrep pulse
 2550 ?        Sl     0:00 /usr/bin/pulseaudio --log-target=syslog
 2555 ?        S      0:00 /usr/libexec/pulse/gconf-helper
 2721 pts/1    S+     0:00 egrep pulse

Looks like it's running.
Comment 6 Matthias Clasen 2008-04-23 12:59:26 EDT
Lennart, any idea why i should be NULL here ?

#2  0x08050e3d in server_info_cb (i=0x0, userdata=0x8474390)
    at pavucontrol.cc:1046
Comment 7 Lennart Poettering 2008-04-23 18:12:47 EDT
This happened in old version of pavucontrol when no devices where configured in
PA. I fixed that a while ago. Please update pavucontrol.
Comment 8 Jay Fenlason 2008-04-24 15:21:29 EDT
Still crashes with latest rawhide.
Comment 9 Matthias Clasen 2008-04-24 20:07:45 EDT
Confirmed on a livecd of todays rawhide - it still crashes.
Comment 10 Matthias Clasen 2008-04-24 20:12:25 EDT
Hmm, it appears you put 0.9.6 into cvs, but never built it, Lennart. Building it
now.

Note You need to log in before you can comment on or make changes to this bug.