Bug 443664 - fence_apc_snmp: invalid status outletStatusOff
Summary: fence_apc_snmp: invalid status outletStatusOff
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cman   
(Show other bugs)
Version: 5.2
Hardware: All
OS: Linux
low
high
Target Milestone: rc
: ---
Assignee: Jim Parsons
QA Contact: GFS Bugs
URL:
Whiteboard:
Keywords: Regression
Depends On:
Blocks: RHEL5u3_relnotes 484095
TreeView+ depends on / blocked
 
Reported: 2008-04-22 18:43 UTC by Nate Straz
Modified: 2009-04-16 22:55 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The Cluster Manager utility (cman) has been updated to version 2.0.97. This applies several bug fixes and enhancements, most notably: * cman now uses the following firmware versions: APC AOS v3.5.7 and APC rpdu v3.5.6. This fixes a bug that prevented the APC 7901 from using simple network management protocol (SNMP) properly. * fence_drac, fence_ilo, fence_egenera, and fence_bladecenter agents now support ssh. * fence_xvmd key files can now be reloaded without restarting. * A single fence method can now support up to 8 fence devices.
Story Points: ---
Clone Of:
: 484095 (view as bug list)
Environment:
Last Closed: 2009-01-20 21:52:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch fence_apc_snmp to accept symbolical and numeric values (810 bytes, patch)
2008-07-08 08:01 UTC, Chris Verhoef
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:0189 normal SHIPPED_LIVE cman bug-fix and enhancement update 2009-01-20 16:05:55 UTC

Description Nate Straz 2008-04-22 18:43:45 UTC
Description of problem:

When I tried fence_apc_snmp on our 64 node cluster I found that it gets confused
by symbolic names for states.  Where fence_apc_snmp was expecting "2" it got
instead "outletStatusOff."  This can be fixed by adding "-Oe" to the snmpget
command line.

Version-Release number of selected component (if applicable):
cman-2.0.84-2.el5

How reproducible:
100%

Steps to Reproduce:
1. /sbin/fence_apc_snmp -a east-apc -n 10
  
Actual results:
Apr 22 13:38:27 north-01 fenced[8694]: fencing node "east-08"
Apr 22 13:38:27 north-01 fenced[8694]: agent "fence_apc_snmp" reports: invalid
status outletStatusOff 
Apr 22 13:38:27 north-01 fenced[8694]: fence "east-08" failed

Expected results:

Apr 22 13:38:32 north-01 fenced[8694]: fencing node "east-08"
Apr 22 13:38:33 north-01 fenced[8694]: fence "east-08" success

Additional info:

Comment 1 Chris Verhoef 2008-07-08 08:01:48 UTC
Created attachment 311239 [details]
Patch fence_apc_snmp to accept symbolical and numeric values

Comment 3 RHEL Product and Program Management 2008-07-23 05:40:41 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 4 Jim Parsons 2008-07-30 13:56:43 UTC
Done, with 456058

Comment 5 Nate Straz 2008-09-17 15:51:40 UTC
I don't see the patch in the latest cman package and it is still failing.

[root@dash-01 ~]# fence_node dash-03
agent "fence_apc_snmp" reports: invalid status outletStatusMSPOn

Comment 6 Kiersten (Kerri) Anderson 2008-09-19 14:31:09 UTC
Please update status on this bug for 5.3.

Comment 7 Jim Parsons 2008-09-19 14:36:17 UTC
This is not ready yet - testing the very latest MIB from APC today.

Comment 8 Kiersten (Kerri) Anderson 2008-09-19 19:32:09 UTC
Marking this as a regression and flagging an exception to get it into rhel 5.3 prior to RC release.

Comment 9 RHEL Product and Program Management 2008-09-19 19:52:13 UTC
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being marked as a blocker for this release.  

Please resolve ASAP.

Comment 11 Dean Jansa 2008-10-15 22:55:07 UTC
I've run with the latest pkgs, this still fails.  I talked with Chris, he can not find the commit which would have included a fix.

Comment 12 Marek Grac 2008-11-04 16:14:43 UTC
Tested on AP7941 (v3.5.6), AP7951 (v2.7), AP7901 (v3.3.4), AP7901 (v3.5.7) on fence_apc_snmp from RHEL53 branch. Fence agent was executed directly from command line. 

Current results:

* SNMP on APC 7901 (v3.3.4/3.3.3) - doesn't work correctly, pointing to oid which does not exist. Upgrade to latest firmware v3.5.7 helps.

* On every other configuration power on & off / reboot / status works correctly

Comment 13 Jim Parsons 2008-11-04 16:29:42 UTC
The fix for this issue is to upgrade to APC AOS v3.5.7 and APC rpdu v3.5.6 firmware. These firmware versions should be used on any AP79XX series switch in order to use fence_apc_snmp.

NOTE: The above should be release noted, methinks.

Marking as MODIFIED as this is a regression in APC code.

Comment 15 Don Domingo 2008-11-17 23:55:57 UTC
this bug is now documented in the RHEL5.3 release notes. please refer to the following link within the next 24 hours or so to view the most current build:
http://documentation-stage.bne.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/5.3/html-single/Release_Notes/

Comment 16 Don Domingo 2008-11-17 23:55:57 UTC
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
The Cluster Manager utility (cman) has been updated to version 2.0.97. This applies several bug fixes and enhancements, most notably:

* cman now uses the following firmware versions: APC AOS v3.5.7 and APC rpdu v3.5.6. This fixes a bug that prevented the APC 7901 from using simple network management protocol (SNMP) properly.

* fence_drac, fence_ilo, fence_egenera, and fence_bladecenter agents now support ssh.

* fence_xvmd key files can now be reloaded without restarting.

* A single fence method can now support up to 8 fence devices.

Comment 19 Sam Bashton 2009-01-07 12:07:06 UTC
This issue still exists in RH5.3 Beta U3.

The previously attached patch no longer works as new changes have been incorporated.  New patch attached.

Comment 20 Sam Bashton 2009-01-07 12:10:12 UTC
(In reply to comment #19)
> This issue still exists in RH5.3 Beta U3.
> 
> The previously attached patch no longer works as new changes have been
> incorporated.  New patch attached.

Previously attached patch does work, and should be included in RH5.3

Comment 21 Marek Grac 2009-01-07 12:28:44 UTC
Attached patch is missing :)

Comment 22 Matt Brodeur 2009-01-20 21:01:14 UTC
The version of fence_apc_snmp in cman-2.0.98-1.el5 (5.3 GA) still has the originally reported problem.  I can reproduce it on every one of the 30-some APC switches in our lab.  These are various models (7911, 7931, 7941, 7952) running various releases from 3.3.3/3.3.4 to 3.5.8/3.5.9.

In every case I've found the 5.3 version fails as shipped, but works after applying the patch from comment #1.

Comment 23 errata-xmlrpc 2009-01-20 21:52:29 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0189.html

Comment 25 Marek Grac 2009-02-04 19:03:32 UTC
Bug cannot be reopened as errata was published. Bug was cloned instead (bug #484095)


Note You need to log in before you can comment on or make changes to this bug.