Bug 443677 - Tray icon scaling incorrectly
Summary: Tray icon scaling incorrectly
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-packagekit   
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Robin Norwood
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-04-22 20:04 UTC by Michael Monreal
Modified: 2008-05-07 17:14 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-07 17:14:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (7.78 KB, image/png)
2008-04-22 20:05 UTC, Michael Monreal
no flags Details
Screenshot / Mockup (5.10 KB, image/png)
2008-04-22 22:32 UTC, Michael Monreal
no flags Details
what i see (28.06 KB, image/png)
2008-05-07 17:13 UTC, Richard Hughes
no flags Details

Description Michael Monreal 2008-04-22 20:04:31 UTC
The packagekit tray icon is scaling incorrectly when adapting to a changed panel
size. Specifically, it seems to stay at 16x16 until the panel is bigger than
32px. Fedora uses a 24x24 panel, at which size the try icon should be the 22x22
version.

This seems like a minor thing at first but the tray icon seems to be a central
part of the packagekit UI, so it should look correct. More than that even:
because the current action is only shown in the lower right corner of the icon
as an "emblem", using smaller icons is even worse: the user has to guess the
current state with the help of a 5x5 (guessed) emblem. Taking today's screen
resolution into account and you will see that fixing this would indeed be important.

Comment 1 Michael Monreal 2008-04-22 20:05:40 UTC
Created attachment 303370 [details]
Screenshot

This shows the packagekit icon next to the network manager and volume applet
icons.

Comment 2 Richard Hughes 2008-04-22 21:30:53 UTC
Do you mean if you resize the panel while the icon is there? I can't reproduce
otherwise.

Comment 3 Michael Monreal 2008-04-22 21:53:12 UTC
I don't resize my panel that much ;)
But for common panel sizes < 30px the icon displayed is too small. I didn't test
much. With the default panel (24px) the notification icon should be 22x22 but it
is 16x16. I don't know it the notification icon was bigger if I had the panel,
say, 26px but at least it only resized when I made the panel 33px.

Comment 4 Michael Monreal 2008-04-22 22:32:46 UTC
Created attachment 303393 [details]
Screenshot / Mockup

To better show what I mean: the upper part shows what I see on the default
sized panel (24px): a 16x16 icon.

The bottom part is a mockup which uses the correct icon (22x22).

Comment 5 Richard Hughes 2008-04-30 08:46:32 UTC
Surely this is a panel issue? g-pk doesn't choose the icon size at all. It just
says "use that iconname".

Comment 6 Michael Monreal 2008-04-30 09:49:32 UTC
Not sure what other apps do, but most seem to work better. Are you using
GtkStatusIcon or the Egg implementation?

Comment 7 Richard Hughes 2008-05-06 17:08:08 UTC
GtkStatusIcon

Comment 8 Richard Hughes 2008-05-07 17:13:23 UTC
Created attachment 304788 [details]
what i see

This is what I see on my F9 laptop.


Note You need to log in before you can comment on or make changes to this bug.