This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 443686 - wpa_cli unable to talk to wpa_supplicant with selinux enabled
wpa_cli unable to talk to wpa_supplicant with selinux enabled
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: wpa_supplicant (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-22 16:56 EDT by tswan
Modified: 2008-04-23 17:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-23 17:20:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description tswan 2008-04-22 16:56:54 EDT
Description of problem:

wpa_cli unable to talk to wpa_supplicant with selinux enabled

Version-Release number of selected component (if applicable):
Fedora 9 PR1

How reproducible:
always

Steps to Reproduce:
1. fresh install (default options)
2. edit /etc/sysconfig/wpa_supplicant and remove -u which prevents
wpa_supplicant from running with dbus, add the appropriate interface and drivers
3. restart wpa_supplicant
4. run wpa_cli as root or as a privileged user 
5. cannot talk to wpa_supplicant
6. run the selinux troubleshooter and you can see wpa_cli is prevented from
talking with wpa_supplicant (even as root)
  
Actual results:
wpa_cli doesn't work


Expected results:
wpa_cli should work

Additional info:
none
Comment 1 Daniel Walsh 2008-04-23 17:20:47 EDT
What AVC are you seeing?  You probably need to customize your policy if you want
this to work.

# grep wpa /var/log/audit/audit.log | audit2allow -M mywpa
# semodule -i mywpa.pp

But since this is local customization it probably will not be supported by the
default SELinux policy.

I am marking this as WONTFIX, for now

Note You need to log in before you can comment on or make changes to this bug.