This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 443692 - pkgconfig version should be 3.5.6, not just 3.5
pkgconfig version should be 3.5.6, not just 3.5
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: sqlite (Show other bugs)
rawhide
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-22 17:27 EDT by Jan Kratochvil
Modified: 2008-09-16 19:18 EDT (History)
3 users (show)

See Also:
Fixed In Version: sqlite-3.5.8-1.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-13 01:56:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jan Kratochvil 2008-04-22 17:27:49 EDT
Description of problem:
2008-04-22 snapshot of the Rawhide xulrunner fails to build due to the
dependency on sqlite-devel.

Version-Release number of selected component (if applicable):
sqlite-devel-3.5.6-2.fc9.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. rpmbuild -bc xulrunner.spec

Actual results:
checking for sqlite3 >= 3.5.4... Requested 'sqlite3 >= 3.5.4' but version of
SQLite is 3.5
configure: error: Library requirements (sqlite3 >= 3.5.4) not met; consider
adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a
nonstandard prefix so pkg-config can find them.

Expected results:
checking for sqlite3 >= 3.5.4... yes

Additional info:
/usr/lib64/pkgconfig/sqlite3.pc
contains
Version: 3.5
while it should contain
Version: 3.5.6
Comment 1 Panu Matilainen 2008-04-23 01:59:58 EDT
Ok, I can see that... but it appears to be deliberate upstream choice, they
munge strip the microversion from so VERSION -> 3.5 and RELEASE -> 3.5.8, and
VERSION is what gets put into the pkgconfig file. Easy enough to change, but
OTOH xulrunner is checking for something that upstream sqlite doesn't provide.

I'll check with sqlite upstream whether it's really deliberate or just a
leftover from something / mishap.
Comment 2 Panu Matilainen 2008-04-23 02:41:27 EDT
Filed upstream at http://www.sqlite.org/cvstrac/tktview?tn=3077
Comment 3 Panu Matilainen 2008-05-13 01:56:09 EDT
Upstream doesn't seem to be reacting... In any case, this is now fixed in rawhide.
Comment 4 Takanori MATSUURA 2008-05-19 04:54:40 EDT
For F9?
Comment 5 Fedora Update System 2008-07-10 12:09:59 EDT
sqlite-3.5.9-1.fc9 has been submitted as an update for Fedora 9
Comment 6 Fedora Update System 2008-09-16 19:18:52 EDT
sqlite-3.5.9-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.