Bug 443694 - Missing hard disk space requirement in release notes
Missing hard disk space requirement in release notes
Status: CLOSED RAWHIDE
Product: Fedora Documentation
Classification: Fedora
Component: release-notes (Show other bugs)
devel
All Linux
low Severity low
: ---
: ---
Assigned To: Release Notes Tracker
Karsten Wade
http://docs.fedoraproject.org/release...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-22 17:32 EDT by Josh Cogliati
Modified: 2009-09-21 17:51 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-25 01:38:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josh Cogliati 2008-04-22 17:32:01 EDT
Description of problem:
At 
http://docs.fedoraproject.org/release-notes/f9preview/en_US/sn-ArchSpecific.html
there is the text:
"The disk space requirements listed below" ...
But, there is no hard disk space requirements listed below.  

Version-Release number of selected component (if applicable):
Version 8.92 (2008-03-17)

How reproducible:
Very.  Has been a problem since at least Fedora 7.

Steps to Reproduce:
1. Load up the release notes
2. Look at the hardware requirements.
3. Notice that there is no disk space given.  
  
Actual results:
No listing of amount of disk space required.

Expected results:
Something on the order of 6 GB.  

Additional info:
It would be helpful if it gave disk space requirements for a minimal, and how
much extra space the Development option, the Office and Productivity option and
the Server option add.
Comment 1 Karsten Wade 2008-04-22 18:27:54 EDT
Looking at that page at the phrase you quoted, it appears three times on that
page, once for each major architecture:

  'The disk space requirements listed below represent the disk space
  taken up by Fedora 9 after installation is complete. However,
  additional disk space is required during installation to support the
  installation environment. This additional disk space corresponds to
  the size of /Fedora/base/stage2.img (on Installation Disc 1) plus
  the size of the files in /var/lib/rpm on the installed system.

  In practical terms, additional space requirements may range from as
  little as 90 MiB for a minimal installation to as much as an
  additional 175 MiB for an "everything" installation. The complete
  packages can occupy over 9 GB of disk space.

  Additional space is also required for any user data, and at least 5%
  free space should be maintained for proper system operation.'

As you may have noted, a few releases ago we stopped trying to be exact on
minimum and maximum install sizes for each release.  Previous to that when
shipping Fedora was "Fedora Core", it had been possible to predict to the MiB
how much space an "everything" install took up.  After the end of the
"everything" install, the combining of internal and external package
repositories, and the dawning of the age of the Fedora spin, it stopped being
possible to predict what the size of the particular install a person had in
their hands would take up.  At that point, we adjusted the content to give the
range, as above.

So, I really don't think this is a bug in the release notes, but I'm curious to
hear back from you what is insufficient in those notes.  Perhaps there are some
additional clues, pointers, or formulas we could be offering users.
Comment 2 Josh Cogliati 2008-04-22 22:40:49 EDT
Okay.  Believe it or not, I managed to read those paragraphs three times and
missed the "The complete packages can occupy over 9 GB of disk space".  How I
managed to do that is reading the first paragraph "The disk space
requirement*s*", and think, okay, I am looking for a list of different disk
space requirements, like back in the day of fedora core 3 (
http://docs.fedoraproject.org/release-notes/fc3/x86/ )  Then I see the second
paragraph "In practical terms, additional space requirements" and think, okay,
this paragraph is about the additional space need beyond the listed amounts, and
head to the next paragraph.  The third paragraph is talking more about
additional disk space requirements such as for the home directories.  So, we
have three paragraphs 1) look for the disk space requirements later 2) You need
more than them to install 3) you need more than the requirement to actually
store your own data.   

A simple fix for this could be that the 9 GB sentence be the first one and drop
the "listed below":
"""The complete packages can occupy over 9 GB of disk space. However, additional
disk space is required during the installation to support the installation
environment. This additional disk space corresponds to the size of
/Fedora/base/stage2.img on Installation Disc 1 plus the size of the files in
/var/lib/rpm on the installed system.

In practical terms, additional space requirements may range from as little as 90
MiB for a minimal installation to as much as an additional 175 MiB for an
"everything" installation. 

Additional space is also required for any user data, and at least 5% free space
should be maintained for proper system operation. """

A better fix might be to leave the paragraphs as are and add something like this
to the bottom (I don't know the exact numbers):
2 GB minimum install
4 GB Basic Install
additional 2 GB Office and Productivity software
additional 3 GB Development Software
additional 1 GB server software
9 GB complete packages

So, I guess my request is to at least rephrase the section so it is more obvious
that 9 GB is the complete DVD install, and possibly add more size possibilities.
Comment 3 Karsten Wade 2008-04-25 01:38:12 EDT
I went for a variation on the first, because we still have the challenge of
predicting package sets for spins.  We might instead suggest that spins publish
their min/max install sizes?

Thanks for catching this one.  After rewording it tonight, it was obvious to me
that we left crufty wording in there from when there used to be a list of the
install min/max (back when there was one package set to install from.)

This is now fixed on the wiki (Docs/Beats/ArchSpecific*) and in the XML in CVS;
these changes should appear in the GA notes thanks to the release slip.

Note You need to log in before you can comment on or make changes to this bug.