Bug 443707 - Files present in /srv
Files present in /srv
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: git (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Chris Wright
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Target
  Show dependency treegraph
 
Reported: 2008-04-22 18:25 EDT by Ignacio Vazquez-Abrams
Modified: 2014-01-21 01:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-11 20:31:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ignacio Vazquez-Abrams 2008-04-22 18:25:12 EDT
This package contains files in /srv, which according to a recent packaging
guideline change is no longer allowed.

http://fedoraproject.org/wiki/Packaging/Guidelines#NoFilesOrDirectoriesUnderSrv

Please ensure that the files are placed elsewhere.
Comment 1 Bug Zapper 2008-05-14 05:58:46 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Jesse Keating 2008-10-03 19:12:10 EDT
Not blocking F10 over this.  Moving to target.  Would like to see some input from the maintainer though, given that this was filed 5+ months ago.
Comment 3 seth vidal 2008-11-17 13:31:27 EST
Looks like a minor patch to the xinetd config file and then to the spec file to mkdir -p another dir instead of /srv/git. I'm not the maintainer but I was just looking it over. easyfix.
Comment 4 Todd Zullinger 2008-12-23 20:48:11 EST
Thanks for fixing this Seth.  Is it desirable to fix this in F-9 as well, or can we close this now that it is fixed in the F-10 and devel branches?

(This is pretty minor, but would renaming to /var/lib/git be acceptable when git-1.6.1 is released and built for devel?  I don't imagine anything in git other than git-daemon will use /var/lib, so just /var/lib/git should be reasonable.  If/when some other part of git needs a place in /var/lib, we could move the daemon stuff to /var/lib/git/daemon and avoid cluttering /var/lib.)

Note You need to log in before you can comment on or make changes to this bug.