This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 443717 - Populating INPUTRC with /etc/inputrc by /etc/profile prevents using ~/.inputrc
Populating INPUTRC with /etc/inputrc by /etc/profile prevents using ~/.inputrc
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: setup (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-22 19:31 EDT by HK Kim
Modified: 2009-02-06 07:08 EST (History)
0 users

See Also:
Fixed In Version: setup-2.6.18-2.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-06 07:08:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description HK Kim 2008-04-22 19:31:35 EDT
Description of problem:

Populating INPUTRC with /etc/inputrc by /etc/profile prevents using ~/.inputrc

Version-Release number of selected component (if applicable):
2.6.14

How reproducible:
Always

Steps to Reproduce:
1. install rawhide
2. login
3. create .inputrc
4. call the program uses readline facility
  
Actual results:
4. .inputrc is not used.

Expected results:
4. .inputrc is respected.

Additional info:
It seems that it's unnecessary since readline library is supposed to do that.
Comment 1 Bug Zapper 2008-05-14 05:59:12 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Tom Lane 2008-06-19 14:11:40 EDT
I've just gotten burnt by this too.  The code in /etc/profile to set INPUTRC is useless since readline started 
to support /etc/inputrc by itself, and it screws up the corner case where ~/.inputrc was just created in the 
current session.  Please remove it.
Comment 3 Ondrej Vasik 2008-12-10 11:22:08 EST
Fixed in rawhide and built as setup-2.7.5-2.fc11, will wait for a while with F-9/F-10 update to see if it is harmless change.
Comment 4 Ondrej Vasik 2009-02-06 07:08:14 EST
Fixed in setup-2.6.18-2.fc9 and setup-2.7.4-3.fc10, closing NEXTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.