Bug 443727 - wifi AR5418 chipset (macbook 2,1) not supported by ath5k
wifi AR5418 chipset (macbook 2,1) not supported by ath5k
Status: CLOSED DUPLICATE of bug 254192
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-22 21:43 EDT by Andrew Farris
Modified: 2008-04-23 08:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-23 08:33:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Farris 2008-04-22 21:43:39 EDT
Description of problem:
Running F9 Preview with kernel-2.6.25-1.fc9.x86_64.  The ath5k driver does not
support my wireless chipset, Atheros AR5418 in my Apple Macbook 2,1 (blackbook
core 2 duo).

Version-Release number of selected component (if applicable):
kernel-2.6.25-1.fc9.x86_64


Actual results:
No interface listed by ifconfig -a after driver loads.

Expected results:
Ath0 and Wifi0 interfaces.

Additional info:
Madwifi-0.9.4-1 from Livna also does not work, but upstream madwifi svn trunk
does work.  I realize this is not Fedora supported, its just a hardware
works/fails bug.

02:00.0 Network controller: Atheros Communications Inc. AR5418 802.11abgn
Wireless PCI Express Adapter (rev 01)
	Subsystem: Apple Computer Inc. Unknown device 0087
	Flags: bus master, fast devsel, latency 0, IRQ 17
	Memory at 90100000 (64-bit, non-prefetchable) [size=64K]
	Capabilities: [40] Power Management version 2
	Capabilities: [50] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable-
	Capabilities: [60] Express Legacy Endpoint, MSI 00
	Capabilities: [90] MSI-X: Enable- Mask- TabSize=1
	Capabilities: [100] Advanced Error Reporting <?>
	Capabilities: [140] Virtual Channel <?>
	Kernel driver in use: ath_pci
	Kernel modules: ath_pci, ath5k
Comment 1 John W. Linville 2008-04-23 08:33:59 EDT

*** This bug has been marked as a duplicate of 254192 ***

Note You need to log in before you can comment on or make changes to this bug.