Bug 443754 - Gramps 3.0 is out
Gramps 3.0 is out
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gramps (Show other bugs)
9
All Linux
medium Severity low
: ---
: ---
Assigned To: Jeffrey C. Ollie
Fedora Extras Quality Assurance
http://www.gramps-project.org/wiki/in...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-23 01:17 EDT by Jack Deslippe
Modified: 2008-12-09 06:37 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-09 06:37:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Spec file for gramps 3.0.1 (9.64 KB, application/octet-stream)
2008-08-04 10:18 EDT, Joseph Harnish
no flags Details
Patch against the current spec file to upgrade to 3.0.3 (4.79 KB, patch)
2008-11-21 11:08 EST, Russell Harrison
no flags Details | Diff
Patch to handle the different BerklyDB versions between F9 and F10 (2.34 KB, patch)
2008-11-21 11:11 EST, Russell Harrison
no flags Details | Diff

  None (edit)
Description Jack Deslippe 2008-04-23 01:17:25 EDT
Gramps 3.0 is out and looks good, could the fedora package be updated to this? 
I notice that the package in the development repo is still at 2.2.10.
Comment 1 Bug Zapper 2008-05-14 05:59:58 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Joseph Harnish 2008-06-06 09:24:17 EDT
Because version 3 requires an upgrade to the DB and such would this have to get
pushed to F10?  
Comment 3 Joseph Harnish 2008-08-04 10:18:19 EDT
Created attachment 313362 [details]
Spec file for gramps 3.0.1

I have attached a quick rework of the spec file for 2.2.10 to build 3.0.1.  I have not tested this in a mock environment so there may be some new dependencies.  It built just fine on Fedora 9 (64bit).
Comment 4 Jack Deslippe 2008-09-13 22:55:23 EDT
Still no updated package even in rawhide...  Perhaps the packager has dropped gramps?  Can I get the rpm you built Joseph?
Comment 5 Jeffrey C. Ollie 2008-09-14 00:21:04 EDT
I've been working on an updated package for rawhide, however given that I haven't had a running rawhide system for a while it's been difficult to test a new package - the dependencies have changed in rawhide so it's taken a while to get a package to build.  I'm taking the plunge and upgrading my laptop to rawhide this weekend so I should be able to do some testing next week.  As I think I've said elsewhere I do not have any plans to update F9 or earlier to gramps 3.x.
Comment 6 Daniel Berrange 2008-10-27 07:09:58 EDT
Any ETA on getting a 3.0.x release into Fedora ?  The upstream project publishes source RPMS for Fedora, so perhaps they'd be interested in maintaining the official Fedora packages directly ? FWIW, the upstream package installs without trouble on Fedora 9, and the database format upgrade worked automatically & flawlessly first time it was run.
Comment 7 Russell Harrison 2008-11-21 11:08:34 EST
Created attachment 324316 [details]
Patch against the current spec file to upgrade to 3.0.3

I've updated the package from CVS with the required changes to update the package from 2.2.10 to 3.0.3.  The package builds and installs for both F9 and F10 and is working properly on both.

I'm also attaching the patch to handle the BerklyDB change in the python shipping with F10 referenced in the spec file changes.
Comment 8 Russell Harrison 2008-11-21 11:11:23 EST
Created attachment 324317 [details]
Patch to handle the different BerklyDB versions between F9 and F10

This patch is needed to run version 3.0.3 on both F9 and F10.  The next version of GRAMPS should include these changes (hopefully) and it won't be required after that.
Comment 9 Fedora Update System 2008-11-21 21:08:35 EST
gramps-3.0.3-0.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/gramps-3.0.3-0.fc10
Comment 10 Fedora Update System 2008-11-26 01:14:22 EST
gramps-3.0.3-0.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gramps'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/f10/FEDORA-2008-10255
Comment 11 Fedora Update System 2008-12-09 06:37:23 EST
gramps-3.0.3-0.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.