Bug 443773 - After the F9 beta install, firstboot is not shown when booting into mode 5
After the F9 beta install, firstboot is not shown when booting into mode 5
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: F9Blocker
  Show dependency treegraph
 
Reported: 2008-04-23 04:37 EDT by Joachim Backes
Modified: 2008-05-09 13:08 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-09 13:08:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda log (61.92 KB, application/octet-stream)
2008-05-02 12:52 EDT, Deji Akingunola
no flags Details
rawhide install log (55.69 KB, application/octet-stream)
2008-05-02 12:52 EDT, Deji Akingunola
no flags Details

  None (edit)
Description Joachim Backes 2008-04-23 04:37:09 EDT
Description of problem:
When booting a fresh installed f9 beta, the I expect that firstboot runs. But
when booting to init mode 5, the graphical boot is not completed, and no
firstboot is shown.
Only if booting in initmode 3, firstboot appears.

Version-Release number of selected component (if applicable):


How reproducible:
Each time

Steps to Reproduce:
1.Install F9 beta
2.boot for the first time
3.
  
Actual results:
No firstboot is shown

Expected results:
firstboot is shown

Additional info:
Comment 1 Chris Lumens 2008-04-23 05:14:01 EDT
Are there any /tmp/firstboot-* files?  If so, please attach them to this bug report.
Comment 2 Joachim Backes 2008-04-23 05:20:53 EDT
I'm sorry, no.
Comment 3 Chris Lumens 2008-04-23 12:38:57 EDT
What do you mean by "the graphical boot is not completed"?  Is something failing
before firstboot has a chance to run, or is it only firstboot that is failing?
Comment 4 Jacek Pliszka 2008-04-23 15:15:34 EDT
I have the same problem with F9-Preview.

After text mode installation  runlevel 5 is default in the inittab.

During the first boot - the first boot is run in text mode but X server 
tries to start and everything hangs...

I found the following workaround:

If installed in text mode, run the first time in the text mode (runlevel 3),
configure X and then run in runlevel 5.

the solution I propose is such:

If installed in text mode - the first boot is in runlevel 3 - without X server.
The default runlevel can be detected and changed later in X configuration.


Comment 5 Jacek Pliszka 2008-04-23 15:17:08 EDT
It would be great to have it fixed before final release as newbies may have
trouble with it. 
Comment 6 Joachim Backes 2008-04-24 00:50:50 EDT
> What do you mean by "the graphical boot is not completed"?
> Is something failing
> before firstboot has a chance to run, or is it only firstboot that is failing?

Nothing fails. My problem is exactly described in comment #4 by
pliszka@phyun0.ucr.edu
Comment 7 Chris Lumens 2008-04-24 10:50:35 EDT
Okay, thanks for the detailed directions.  I am now able to reproduce and see
what's going on.
Comment 8 Jeremy Katz 2008-04-25 01:33:08 EDT
This should be fixed in tomorrow's rawhide I believe
Comment 9 Chris Lumens 2008-04-25 04:55:50 EDT
Yep, just verified that it worked.  Thanks for doing the rebuild.
Comment 10 Deji Akingunola 2008-05-01 21:49:55 EDT
I completed fresh 2 installations yesterday and today, and in both cases
firstboot failed to run after rebooting into the new installations. I noticed
that if I restart the system after firstboot failed, it will run only if switch
rhgb to 'detail view' on restarting. And I also noticed it spewed out 2 lines of
error saying something like 'loading language module failed, skipping' (sorry i
could read the exact error, it went away too fast).  
Comment 11 Chris Lumens 2008-05-02 11:27:56 EDT
What tree did you install with?
Comment 12 Deji Akingunola 2008-05-02 12:13:53 EDT
(In reply to comment #11)
> What tree did you install with?
Rawhide
Comment 13 Bill Nottingham 2008-05-02 12:27:49 EDT
I noticed this on a rawhide install yesterday as well.
Comment 14 Jeremy Katz 2008-05-02 12:31:04 EDT
Can you attach /root/install.log and /var/log/anaconda.log from your install?  I
did a few installs with yesterday's rawhide and had firstboot come up fine.
Comment 15 Deji Akingunola 2008-05-02 12:52:25 EDT
Created attachment 304401 [details]
anaconda log
Comment 16 Deji Akingunola 2008-05-02 12:52:53 EDT
Created attachment 304402 [details]
rawhide install log
Comment 17 Bill Nottingham 2008-05-02 13:06:54 EDT
My testing shows that it works if rhgb is not running.
Comment 18 Bill Nottingham 2008-05-02 13:38:25 EDT
Traceback (most recent call last):
  File "/usr/sbin/firstboot", line 170, in <module>
    moduleList = loadModules(config.moduleDir, mode)
  File "/usr/lib64/python2.5/site-packages/firstboot/loader.py", line 93, in
loadModules
    displayException(module=module)
  File "/usr/lib64/python2.5/site-packages/firstboot/exceptionWindow.py", line
95, in displayException
    ExceptionWindow(text, module=module)
  File "/usr/lib64/python2.5/site-packages/firstboot/exceptionWindow.py", line
32, in __init__
    import gtk
  File "/usr/lib64/python2.5/site-packages/gtk-2.0/gtk/__init__.py", line 79, in
<module>
    _init()
  File "/usr/lib64/python2.5/site-packages/gtk-2.0/gtk/__init__.py", line 67, in
_init
    _gtk.init_check()
RuntimeError: could not open display
Comment 19 Bill Nottingham 2008-05-02 13:42:54 EDT
Clearing 444010 - that's not the cause of this issue (at least not this
incarnation of it.)
Comment 20 Bill Nottingham 2008-05-02 15:32:28 EDT
Fixed in rhgb-9.0.0-6.fc9.
Comment 21 Bill Nottingham 2008-05-09 13:08:26 EDT
Verified.

Note You need to log in before you can comment on or make changes to this bug.