Bug 443784 - Command "yumdownloader" throws an exception and install quits when installing kit hpc.
Command "yumdownloader" throws an exception and install quits when installing...
Status: CLOSED DUPLICATE of bug 378911
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum-rhn-plugin (Show other bugs)
5.1
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: John Matthews
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-23 06:09 EDT by liqi0711
Modified: 2008-04-23 10:11 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-23 10:11:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description liqi0711 2008-04-23 06:09:47 EDT
Description of problem:


Version-Release number of selected component (if applicable):
[root@TestRH ~]# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 5.1 (Tikanga)
[root@TestRH ~]# arch
x86_64
[root@TestRH ~]# 


How reproducible:
Install HPC kit via red hat network channel. 

Steps to Reproduce:
1. Install RHEL5.1 server 64 bit OS with full package.
2. Register the test machine into the redhat network and select redhat hpc beta 
solution channel.
3. On the test machine console, type the command: yum install ocs
4. Source /etc/profile.d/kusuenv.sh and then run ocs-setup
5. Then run command: yum install ocs-kit-hpc
6. Then run the download script: ./install-kit-hpc as below:
[root@TestRH sbin]# ./install-kit-hpc
Loading "rhnplugin" plugin
Loading "installonlyn" plugin
rhel-x86_64-server-5      100% |=========================| 1.4 kB    00:00     
kusu-installer-ClusterSto 100% |=========================| 1.3 kB    00:00     
kusu-installer-Server     100% |=========================| 1.1 kB    00:00     
kusu-installer-VT         100% |=========================| 1.3 kB    00:00     
rhel-x86_64-server-hpc-5- 100% |=========================| 1.2 kB    00:00     
kusu-installer-Cluster    100% |=========================| 1.3 kB    00:00     
atlas-3.6.0-12.el5.x86_64 100% |=========================| 4.0 MB    00:18     
atlas-devel-3.6.0-12.el5. 100% |=========================| 5.5 MB    00:27     
blacs-mpich1-gnu-20000224 100% |=========================|  70 kB    00:01     
blacs-mvapich1-gnu-200002 100% |=========================|  70 kB    00:01     
blacs-openmpi-gnu-2000022 100% |=========================|  73 kB    00:01     
bonnie++-1.03a-6.el5.x86_ 100% |=========================|  44 kB    00:00     
component-benchmarking-to 100% |=========================| 1.9 kB    00:00     
component-hpc-libraries-0 100% |=========================| 1.9 kB    00:00     
component-mpich1-librarie 100% |=========================| 1.9 kB    00:00     
component-mpich2-librarie 100% |=========================| 1.8 kB    00:00     
component-mvapich1-librar 100% |=========================| 1.9 kB    00:00     
component-mvapich2-librar 100% |=========================| 1.9 kB    00:00     
component-openmpi-librari 100% |=========================| 1.9 kB    00:00     
fftw3-3.1.2-5.el5.x86_64. 100% |=========================| 1.0 MB    00:05     
fftw3-devel-3.1.2-5.el5.x 100% |=========================| 1.7 MB    00:06     
hdf5-1.6.6-2.x86_64.rpm   100% |=========================| 1.5 MB    00:04     
hdf5-mpich1-gnu-1.6.6-3.x 100% |=========================| 6.6 MB    00:18     
hdf5-openmpi-gnu-1.6.6-2. 100% |=========================| 4.9 MB    00:20     
iozone-3-3.el5.x86_64.rpm 100% |=========================| 259 kB    00:01     
iperf-2.0.2-4.1.el5.x86_6 100% |=========================|  50 kB    00:02     
kit-hpc-0.1-2.x86_64.rpm  100% |=========================| 3.3 kB    00:00     
linpack-mpich1-gnu-1.0a-2 100% |=========================| 236 kB    00:01     
linpack-mvapich1-gnu-1.0a 100% |=========================|  87 kB    00:01     
linpack-openmpi-gnu-1.0a- 100% |=========================|  89 kB    00:01     
mpich1-ethernet-gnu-1.2.7 100% |=========================| 4.4 MB    00:13     
mpich2-ethernet-gnu-1.0.6 100% |=========================| 2.7 MB    00:04     
mvapich1-infiniband-gnu-0 100% |=========================| 6.5 MB    01:22     
mvapich2-infiniband-gnu-1 100% |=========================| 2.6 MB    01:13     
netcdf-3.6.1-4.el5.x86_64 100% |=========================| 160 kB    00:07     
netcdf-devel-3.6.1-4.el5. 100% |=========================| 364 kB    00:12     
openmpi-interconnects-gnu 100% |=========================| 2.9 MB    01:05     
scalapack-mpich1-gnu-1.8. 100% |=========================|  34 MB    17:53     
scalapack-mvapich1-gnu-1. 100% |=========================|  38 MB    18:44     
scalapack-openmpi-gnu-1.8 100% |=========================|  59 MB    30:45     
Traceback (most recent call last):
  File "/usr/bin/yumdownloader", line 191, in ?
    main()
  File "/usr/bin/yumdownloader", line 181, in main
    path = repo.getPackage(download)
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 447, in 
getPackage
    cache=cache
  File "/usr/lib/yum-plugins/rhnplugin.py", line 209, in _getFile
    start, end, copy_local, checkfunc, text, reget, cache)
  File "/usr/lib/yum-plugins/rhnplugin.py", line 298, in _noExceptionWrappingGet
    return result
UnboundLocalError: local variable 'result' referenced before assignment
Error downloading packages for kit
[root@TestRH sbin]# 
  
Actual results: yumdownloader throws exception and hpc kit fail to install.

Expected results:
hpc kit can be successfully installed.
Comment 1 Nils Philippsen 2008-04-23 06:35:36 EDT
That's not a problem in the package, but yumdownloader (or other yum code).
Changing component.
Comment 2 James Antill 2008-04-23 09:44:18 EDT
 This is an old bug, I'm sure a newer yum-rhn-plugin fixes it ... but I can't
find the BZ right now ... reassigning.
Comment 3 John Matthews 2008-04-23 10:11:35 EDT

*** This bug has been marked as a duplicate of 378911 ***

Note You need to log in before you can comment on or make changes to this bug.