Bug 44379 - Disk druid don't add lba32 to lilo.conf when making a raid array above cyl 1024
Summary: Disk druid don't add lba32 to lilo.conf when making a raid array above cyl 1024
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-13 08:34 UTC by Geir Thomassen
Modified: 2007-04-18 16:33 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-13 08:34:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Geir Thomassen 2001-06-13 08:34:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.2-2 i686; en-US; rv:0.9.1)
Gecko/20010607

Description of problem:
Disk druid (anaconda) need to add the "lba32" option instead of the
"linear" option to lilo.conf when making a bootable raid array above cyl
1024. The result is that lilo fails to install, and the system won't boot.

How reproducible:
Always

Steps to Reproduce:
1.Create two partitions on two discs above cyl 1024
2.Add these two partitions to a raid 1 array (eg. md0) and assign this
array to / (root)
3.Continue installation, you will get an error message when anaconda tries
to run lilo.
4. Restart ....
	

Actual Results:  Lilo can't boot the system since lilo.conf was created
with the linear option instead of lba32. You have to boot on a floppy, and
fix lilo.conf.

Additional info:

Comment 1 Brent Fox 2001-06-21 19:19:59 UTC
The entire partitioning subsystem is being rewritten, so this bug should not
appear in the future.


Note You need to log in before you can comment on or make changes to this bug.