Bug 443791 - Just installed sunbird gives when launched transparent window and hangs
Just installed sunbird gives when launched transparent window and hangs
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: sunbird (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-23 07:48 EDT by J.Jansen
Modified: 2008-08-13 11:43 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-13 11:43:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
starce log (4.25 MB, text/plain)
2008-04-23 09:27 EDT, J.Jansen
no flags Details

  None (edit)
Description J.Jansen 2008-04-23 07:48:46 EDT
Description of problem:
Just installed sunbird gives when launched transparent window and hangs

Version-Release number of selected component (if applicable):
sunbird-0.7-10.fc8

How reproducible:
always

Steps to Reproduce:
1.install sunbird with yum
2.launche it from the gnome menu
3.
  
Actual results:
a window pops up containing the current date in the title showing a this month
calendar and today. The rest of the window is transparent. For the rest sunbird
seems to hang.

Expected results:
Nice calendar program in the window


Additional info:
Tried on both i686 and x86-64.
Comment 1 Lubomir Kundrak 2008-04-23 08:29:53 EDT
Hm, this does not seem right.

I am wondering what is the sunbird doing (probably it is loading remote
calendars or something like that.) Is this a clean installation and first run,
or was it already configured?

To see what happens, please try either the following:

1.) Install "strace" package, and run sunbird from Terminal as follows:

$ strace -f -o sunbird-strace.log sunbird

When the sunbird enters the state you described above, please terminate it and
attache the sunbird-strace.log here. (Before doing so, please open it in a text
ediror and ensure it contains no private data, such as passwords. In case it
does, please delete it. Also, you might want to attach it as private attachment).

2.) Do "debuginfo-install sunbird", run sunbird, and once it freezes please
attach the debugger as follows:

$ gdb -p `pidof sunbird`

Once you get GDB prompt, obtain the stack traces as follows:

(gdb) set pagination off
(gdb) set logging file sunbird-gdb.log
(gdb) set logging on
(gdb) thread apply all bt
(gdb) quit

Please attach the sunbird-gdb.log file here.

Thanks!
Comment 2 J.Jansen 2008-04-23 09:27:27 EDT
Created attachment 303490 [details]
starce log

Strace was the easiest (already installed)

It is just a fresh install and a first run.
Comment 3 Lubomir Kundrak 2008-04-23 10:49:46 EDT
2330  writev(23, [{"*** glibc detected *** ", 23},
{"/usr/lib64/sunbird-0.7/sunbird-b"..., 34}, {": ", 2}, {"free(): invalid
pointer", 23}, {": 0x", 4}, {"00000000018470b0", 16}, {" ***\n", 5}], 7) = 107

Hm, it seems that sunbird crashed for some reason (no it did not close yet).

Does this allways happen? Do you allways see the "*** glibc detected ..."
message followed the backtrace when run sunbird in terminal?

Have you tried creating another profile and using it by running "sunbird
-ProfileManager"?

Also, I will try to build sunbird-0.8 for F8 and post you a link to it, so that
you can try if you can reproduce it with later version.
Comment 4 J.Jansen 2008-04-24 02:17:11 EDT
Yes I always see : *** glibc detected ...

I'm not sure how to create another profile. Is sunbird not creating one the first
time it runs? I think this one is created in ~/.mozilla/sunbird. Before
installing sunbird I did not have this directory. So it must be created before
the program hangs.

Lets hope that 0.8 will help.
Comment 5 Lubomir Kundrak 2008-04-24 04:59:00 EDT
(In reply to comment #4)
> Yes I always see : *** glibc detected ...

This is too bad. Do you have a fully-updated clean installation?

> I'm not sure how to create another profile. Is sunbird not creating one the first
> time it runs? I think this one is created in ~/.mozilla/sunbird. Before
> installing sunbird I did not have this directory. So it must be created before
> the program hangs.

Yep, you're right. You can either force sunbird to create a default profile by
moving .mozilla/sunbird away, or can create one by hand with "sunbird
-ProfileManager"

> Lets hope that 0.8 will help.

Seems like the check for the tag being in respective branch is in effect even
for scratch builds, and 0.8 was never in F-8 branch, so the build failed. I can
try creating a branch with 0.8 for F-8 and building that though.
Comment 6 J.Jansen 2008-04-24 06:04:07 EDT
>This is too bad. Do you have a fully-updated clean installation?
as far as I know. I just did a yum (from yumex) yesterday to install the package.
I got no error messages.

>Yep, you're right. You can either force sunbird to create a default profile by
>moving .mozilla/sunbird away, or can create one by hand with "sunbird
>-ProfileManager"
I was running it for the first time so it is a fresh/default profile.
Running with -ProfileManager and creating a new profile results in the same hang.


Comment 8 J.Jansen 2008-06-09 09:15:30 EDT
After an upgrade to F9 the problem is gone. So the problem seems to be limited
to F8. (this means from now on I do not have a machine to reproduce the problem)

Note You need to log in before you can comment on or make changes to this bug.