Bug 443793 - Bad epoch dependencies in kdebase4-devel
Bad epoch dependencies in kdebase4-devel
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Kevin Kofler
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-23 08:25 EDT by Mary Ellen Foster
Modified: 2010-12-07 13:42 EST (History)
9 users (show)

See Also:
Fixed In Version: 4-14.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-29 17:00:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Possible specfile patch (1.60 KB, patch)
2008-04-23 08:43 EDT, Mary Ellen Foster
no flags Details | Diff

  None (edit)
Description Mary Ellen Foster 2008-04-23 08:25:59 EDT
Description of problem:
kdebase4-devel for Fedora 8 has an RPM dependency on "kdebase4-libs =
%{epoch}:4.0.2-2.fc8". That looks like an unexpanded macro in the spec file, and
breaks any attempt to install it.

It looks like the "Epoch" tag in the spec file only gets included if 0%{?fedora}
> 8, so for the Fedora 8 version there's no epoch defined and a whole lot of
Requires: tags get broken.

Version-Release number of selected component (if applicable):
kdebase4-devel-4.0.2-2.fc8
Comment 1 Mary Ellen Foster 2008-04-23 08:43:22 EDT
Created attachment 303487 [details]
Possible specfile patch

I don't fully understand the implications of changing this, so take this patch
with a large grain of salt.
Comment 2 Mary Ellen Foster 2008-04-23 08:48:00 EDT
Ah, it looks like the spec file in Rawhide already deals with this issue better
than my hack did. It would be nice to rebuild that for Fedora 8 too.
Comment 3 Kevin Kofler 2008-04-23 09:22:10 EDT
There's already a development platform update to KDE 4.0.3 pending for F7 and 
F8.
Comment 4 Fedora Update System 2008-04-29 17:00:04 EDT
kde-filesystem-4-14.fc8, kdebase4-4.0.3-9.fc8, kdebase-runtime-4.0.3-10.fc8.1, kdepimlibs-4.0.3-3.fc8, kdelibs4-4.0.3-7.fc8, qt4-4.3.4-11.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.