This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 443796 - libvirt is not built with Fedora iptables/lokkit integration
libvirt is not built with Fedora iptables/lokkit integration
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Target
  Show dependency treegraph
 
Reported: 2008-04-23 08:51 EDT by Mark McLoughlin
Modified: 2008-04-28 05:24 EDT (History)
1 user (show)

See Also:
Fixed In Version: libvirt-0.4.2-2.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-28 05:24:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
libvirt-lokkit.patch (1.02 KB, patch)
2008-04-23 08:51 EDT, Mark McLoughlin
no flags Details | Diff

  None (edit)
Description Mark McLoughlin 2008-04-23 08:51:11 EDT
Recent versions of libvirt have code to use lokkit --custom-rules to ensure that
libvirt's iptables rules are retained even if e.g. the user changes the firewall
config or restarts iptables.

However, we don't currently build libvirt with this support. The attached patch
should fix that.

Note: I've only tested this on Fedora 9, but AFAIK it should work on Fedora 8 too.
Comment 1 Mark McLoughlin 2008-04-23 08:51:11 EDT
Created attachment 303488 [details]
libvirt-lokkit.patch
Comment 2 Daniel Veillard 2008-04-23 09:47:00 EDT
Hum, that's not in the upstream spec file, that's the first thing to do,
otherwise looks fine to me, obviously,

Daniel
Comment 3 Mark McLoughlin 2008-04-28 05:24:07 EDT
Okay, built libvirt-0.4.2-2.fc9 and libvirt-0.4.2-2.fc10

Not sending the patch upstream, since the upstream spec file seems to not be
including fedora specific stuff and this is fedora specific

Not requesting the build be tagged in dist-f9 because it should be fine to just
have as an update

* Mon Apr 28 2008 Mark McLoughlin <markmc@redhat.com> - 0.4.2-2.fc9
- Enable lokkit support (#443796)

Note You need to log in before you can comment on or make changes to this bug.