Bug 443802 - kdump_pre is not accepted in /etc/kdump.conf
kdump_pre is not accepted in /etc/kdump.conf
Status: CLOSED DUPLICATE of bug 436982
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kexec-tools (Show other bugs)
5.2
All Linux
low Severity medium
: rc
: ---
Assigned To: Neil Horman
Red Hat Kernel QE team
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-23 09:49 EDT by Charlotte Richardson
Modified: 2009-09-09 01:15 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-23 09:58:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charlotte Richardson 2008-04-23 09:49:22 EDT
Description of problem:
Cannot set a kdump_pre script in /etc/kdump.conf.


Version-Release number of selected component (if applicable):
/sbin/kexec -v
kexec-tools-testing 20070330 released 30th March 2007

How reproducible:
Always


Steps to Reproduce:
1. Add kdump_pre some_script to /etc/kdump.conf
2. service kdump restart
  
Actual results:
Error "Unsupported type kdump_pre".


Expected results:
Should work! We need to be able to use both a kdump_pre and a kdump_post 
script. (As an aside, I have not gotten either of them to actually work even 
after fixing this bug, because no matter where I put the scripts, even if I 
list them in extra_bins in the kdump.conf file, the kdump kernel cannot 
actually find them to run. I'm surely missing something... please let me know 
what it is!)


Additional info:

There are two problems here.

1) /sbin/mkdumprd is missing a case for kdump_pre in the main loop that reads 
config_opt lines from kdump.conf and so drops into the code that produces that 
error message, which would normally be from an unsupported file system type. 
It should do nothing, the same as it does for kdump_post.

2) Also, /etc/rc.d/init.d/kdump does not check for kdump_pre or run it if 
there is one.
Comment 1 Neil Horman 2008-04-23 09:58:54 EDT
fixed in kexec-tools-1.102pre-19.el5.

Also, just so that you know, the pre and post scripts are only meant to be run
immeidately before and after a dump capture when configured to happen in the
initramfs (i.e. an dump target must be specified in /etc/kdump.conf)

*** This bug has been marked as a duplicate of 436982 ***

Note You need to log in before you can comment on or make changes to this bug.