Bug 443845 - Fedora 9 Preview Live: liveinst doesn't use the language chosen by the user
Fedora 9 Preview Live: liveinst doesn't use the language chosen by the user
Status: CLOSED DUPLICATE of bug 443408
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-23 13:02 EDT by Ville-Pekka Vainio
Modified: 2008-04-23 22:15 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-23 22:15:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ville-Pekka Vainio 2008-04-23 13:02:33 EDT
Description of problem:
When using liveinst in Fedora 9 Desktop/GNOME Live image, the liveinst/anaconda
part is in English even when another language was chosen in GDM and the system
uses that language in general.

Here's a screenshot of the output of "env", which shows that $LANG is
fi_FI.utf8: http://vpv.fedorapeople.org/misc/fedora9-pr-env.png

Here's a screenshot of anaconda started with the liveinst command and after a
couple of "Next" clicks: http://vpv.fedorapeople.org/misc/fedora9-pr-anaconda.png

Please note that some of the output anaconda prints to the terminal is in the
language chosen in GDM, in this case Finnish. "Tunnistetaan näytönohjainta"
would be ~"Detecting video card" in English and at 12:35:59 it printed
~"Starting graphical installation". Also note that the Finnish keymap is chosen,
but that doesn't have any effect on the language (well, maybe it shouldn't,
anyway...)

Version-Release number of selected component (if applicable):
Fedora 9 Desktop/GNOME Preview Live (I don't know the exact anaconda version,
but you probably do...)


How reproducible:
Always

Steps to Reproduce:
1. Boot the live image
2. Choose the language (such as Finnish) from GDM
3. Start liveinst either from the desktop icon or from the terminal
  
Actual results:
Observe Finnish translations everywhere else on the desktop, but missing from
anaconda/liveinst

Expected results:
Anaconda/liveinst should also be translated (in this specific case) in Finnish,
the translations are provided and they have worked in the DVD install.

Additional info:
I know the F-9 release is near and I understand if this won't/can't be fixed in
time for it. I hope this could be fixed at least for F-10.
Comment 1 Jeremy Katz 2008-04-23 22:15:56 EDT

*** This bug has been marked as a duplicate of 443408 ***

Note You need to log in before you can comment on or make changes to this bug.