This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 443878 - mkdumprd creates incomplete initrd for LVM: missing libreadline.5.so
mkdumprd creates incomplete initrd for LVM: missing libreadline.5.so
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kexec-tools (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Neil Horman
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-23 16:00 EDT by Frank Ch. Eigler
Modified: 2008-09-28 05:44 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.102pre-10.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-10 03:10:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch to correctly pull in lvm dso's (625 bytes, patch)
2008-04-23 22:06 EDT, Neil Horman
no flags Details | Diff
qemu screendump (6.82 KB, image/png)
2008-06-26 16:59 EDT, Frank Ch. Eigler
no flags Details
patch to include busybox in bin list (560 bytes, patch)
2008-07-08 08:38 EDT, Neil Horman
no flags Details | Diff

  None (edit)
Description Frank Ch. Eigler 2008-04-23 16:00:08 EDT
kexec-tools-1.102pre-8.fc9.i386 creates an initrd that fails to start
up during a forced or unforced crash.  The LVM initialization stuff
fails because of a missing shared library (libreadline.5.so) in the
image.  So, /sysroot doesn't get mounted and the crash dumping process
stops at an impotent "#" command line.
Comment 1 Neil Horman 2008-04-23 16:19:02 EDT
Oops, I see the problem.  Thanks frank.  I'll fix it shortly.
Comment 2 Neil Horman 2008-04-23 22:06:23 EDT
Created attachment 303564 [details]
patch to correctly pull in lvm dso's

Frank, this should ensure that all the libs that lvm depends on get pulled in. 
Can you patch the mkdumprd script with this patch and verify that it fixes the
problem?  Thanks!
Comment 3 Frank Ch. Eigler 2008-04-23 22:29:36 EDT
Yeah, $bin seems to work.  In another part of the script ($KDUMP_CONFIG_FILE,
adding dmsetup and kpartx), $bin is reset instead of concatenated, which has
to be fixed too.
Comment 4 Neil Horman 2008-04-24 13:30:59 EDT
fixed in -10.fc9.  Thanks frank!
Comment 5 Bug Zapper 2008-05-14 06:01:58 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Frank Ch. Eigler 2008-06-10 13:13:06 EDT
On rawhide, 1.102-pre-11.fc10.i386 fails almost the same was as in the original 
report; this time /bin/msh blocking on libcrypt.so.1
Comment 7 Neil Horman 2008-06-11 06:53:41 EDT
Frank, I don't understand what the above means, /bin/msh is a link to
/sbin/busybox in the initramfs, and busybox is a static executable.  I did
notice howeer that somehow I missed adding the previous fix to rawhide, so I've
done that in -12.fc10, which will be available in koji shortly.  Give that a try
if you would.  Thanks!
Comment 8 Frank Ch. Eigler 2008-06-26 14:36:14 EDT
Sorry dude, 0:1.102pre-12.fc10 still misses libcrypt.so.1
Comment 9 Neil Horman 2008-06-26 14:44:06 EDT
Can you please send me the console log of your kdump kernel boot?  I still fail
to see how msh can block on libcrypt given that busybox is a static binary
(unless that has changed recently.  I can fix this, but I'd really like to know
what requires libcrypt.so.1 and how it pulls that requirement in that we're
missing it first.  Thanks!
Comment 10 Frank Ch. Eigler 2008-06-26 16:59:44 EDT
Created attachment 310382 [details]
qemu screendump

note:

/bin/msh: error while loading shared libraries: libcrypt.so.1: cannot open
shared object file
Comment 11 Neil Horman 2008-07-08 08:38:02 EDT
Created attachment 311261 [details]
patch to include busybox in bin list

I don't see the same problem as you on my F-9 system using the latest
kexec-tools, but I'm using a backlevel busybox.  It looks like F10 busybox may
be trying to move to a dynamic build.  This patch should help that.  Give it a
try if you would please.  If it doesn't help, please attach the initrd that
your system is building for kdump, I'd like to look through it by hand. 
Thanks!
Comment 12 Frank Ch. Eigler 2008-07-13 08:56:20 EDT
Yup, that worked.
Comment 13 Neil Horman 2008-07-14 11:03:03 EDT
Fixed in F-9 and rawhide.  Thanks!
Comment 14 Fedora Update System 2008-07-14 11:03:05 EDT
kexec-tools-1.102pre-10.fc9 has been submitted as an update for Fedora 9
Comment 15 Fedora Update System 2008-07-15 08:17:48 EDT
kexec-tools-1.102pre-10.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2008-07-26 02:01:24 EDT
kexec-tools-1.102pre-10.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 David Juran 2008-08-12 10:18:50 EDT
I'm still seeing the original problem with libreadline.so.5 missing with kexec-tools-1.102pre-10-fc9
Comment 18 Neil Horman 2008-08-12 11:23:51 EDT
apparently the change didn't get picked up.  Fixed in -11
Comment 19 Fedora Update System 2008-08-12 12:28:47 EDT
kexec-tools-1.102pre-12.fc9 has been submitted as an update for Fedora 9
Comment 20 Fedora Update System 2008-09-10 03:10:53 EDT
kexec-tools-1.102pre-12.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 21 Pontus Enhager 2008-09-10 13:28:51 EDT
as i said in bug 
https://bugzilla.redhat.com/show_bug.cgi?id=459542

i - at the time i filed that bug did already use 

kexec-tools-1.102pre-12.fc9.x86_64

which i have used to date - and is now pushed to f9

unless something not mentioned in the changelog happened (last entry 12th Aug), i'd say that the bug still persists - i have not checked today though - should i ?
Comment 22 Pontus Enhager 2008-09-28 05:44:29 EDT
please disregard from last vomment - wrong bug...
sorry for the confusion

Note You need to log in before you can comment on or make changes to this bug.