Bug 443902 - RT kernel panic: gart_iommu_hole_init() fails to allocate aperture memory
RT kernel panic: gart_iommu_hole_init() fails to allocate aperture memory
Status: CLOSED DUPLICATE of bug 466341
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: realtime-kernel (Show other bugs)
1.0
All Linux
high Severity high
: ---
: ---
Assigned To: Steven Rostedt
http://rhts.redhat.com/cgi-bin/rhts/t...
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-23 18:51 EDT by Clark Williams
Modified: 2008-12-16 10:32 EST (History)
6 users (show)

See Also:
Fixed In Version: 2.6.24.7-71.el5rt
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-16 10:32:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
boot log of kernel with aperture alloc changed to __alloc_bootmem_low (7.10 KB, text/plain)
2008-08-05 22:24 EDT, Clark Williams
no flags Details

  None (edit)
Description Clark Williams 2008-04-23 18:51:54 EDT
Description of problem:
Kernel panic on booting hp-dl585-02.rhts.boston.redhat.com. 

Version-Release number of selected component (if applicable):
kernel-rt-2.6.24.4-46.el5rt

How reproducible:
Unknown

Additional info:
This has been seen before on HP systems. The error is when
gart_iommu_hole_init() fails to allocate memory for the AGP aperture and has the
following traceback:
Cannot allocate aperture memory hole (ffff810100000000,65536K)
Kernel panic - not syncing: Not enough memory for aperture
Pid: 0, comm: swapper Not tainted 2.6.24.4-46.el5rt #1

Call Trace:
 [<ffffffff8103b33c>] panic+0xaf/0x169
 [<ffffffff814b6a8f>] ? __alloc_bootmem_nopanic+0x31/0x5c
 [<ffffffff814affaa>] gart_iommu_hole_init+0x4b4/0x57f
 [<ffffffff8105c282>] ? rt_up+0x29/0x52
 [<ffffffff8128bb9e>] ? _etext+0x0/0x3f92
 [<ffffffff814aa400>] pci_iommu_alloc+0x9/0x1a
 [<ffffffff814b153f>] mem_init+0x24/0x16d
 [<ffffffff814a2aaa>] start_kernel+0x258/0x329
 [<ffffffff814a2119>] _sinittext+0x119/0x120
Comment 1 Clark Williams 2008-04-23 18:52:48 EDT
test logs with backtraces:

http://rhts.redhat.com/cgi-bin/rhts/test_log.cgi?id=2811732

Comment 2 Clark Williams 2008-06-11 15:11:49 EDT
Where are we on this bug? I've seen a couple of panics in RHTS with this system
and I wonder if we have bad h/w or if we need to ask the lab guys to change a
BIOS setting?
Comment 3 Clark Williams 2008-07-07 12:36:01 EDT
Looks like CONFIG_DMAR was the culprit. Fixed in -71
Comment 4 Jeff Burke 2008-07-30 22:35:31 EDT
Clark,
 Looks like it is back in 2.6.24.7-75.el5rt :(

http://rhts.redhat.com/cgi-bin/rhts/test_log.cgi?id=3785310

<snip>
Your BIOS doesn't leave a aperture memory hole
Please enable the IOMMU option in the BIOS setup
This costs you 64 MB of RAM
Cannot allocate aperture memory hole (ffff810100000000,65536K)
Kernel panic - not syncing: Not enough memory for aperture
Pid: 0, comm: swapper Not tainted 2.6.24.7-75.el5rt #1

Call Trace:
 [<ffffffff8103ca80>] panic+0xaf/0x160
 [<ffffffff814b8aa7>] ? __alloc_bootmem_nopanic+0x31/0x5c
 [<ffffffff814b1ee0>] gart_iommu_hole_init+0x4b7/0x582
 [<ffffffff8105fe60>] ? rt_up+0x29/0x52
 [<ffffffff8128d621>] ? _etext+0x0/0x3fbf
 [<ffffffff814ac3a1>] pci_iommu_alloc+0x9/0x15
 [<ffffffff814b3460>] mem_init+0x24/0x16d
 [<ffffffff814a4aa2>] start_kernel+0x258/0x329
 [<ffffffff814a4119>] _sinittext+0x119/0x120
</snip>
Comment 5 Clark Williams 2008-08-05 12:04:57 EDT
bumping priority/severity and reassigning to rostedt
Comment 6 Clark Williams 2008-08-05 22:22:35 EDT
Tried modifying the allocation mechanism in arch/x86/kernel/aperture_64.c, from using  __alloc_bootmem_nopanic() to  __alloc_bootmem_low() and got the following panic message:

Your BIOS doesn't leave a aperture memory hole
Please enable the IOMMU option in the BIOS setup
This costs you 64 MB of RAM
low bootmem alloc of 67108864 bytes failed!
Kernel panic - not syncing: Out of low memory
Pid: 0, comm: swapper Not tainted 2.6.24.7-rt14 #4

Call Trace:
 [<ffffffff8103ca94>] panic+0xaf/0x160
 [<ffffffff814b8829>] ? __alloc_bootmem_core+0x12c/0x2e5
 [<ffffffff814b8a6d>] __alloc_bootmem_low+0x73/0x7c
 [<ffffffff814b1e52>] gart_iommu_hole_init+0x429/0x582
 [<ffffffff8105fe74>] ? rt_up+0x29/0x52
 [<ffffffff8128d631>] ? _etext+0x0/0x3fbf
 [<ffffffff814ac3a1>] pci_iommu_alloc+0x9/0x15
 [<ffffffff814b3460>] mem_init+0x24/0x16d
 [<ffffffff814a4aa2>] start_kernel+0x258/0x329
 [<ffffffff814a4119>] _sinittext+0x119/0x120


(full boot log attached)
Comment 7 Clark Williams 2008-08-05 22:24:53 EDT
Created attachment 313513 [details]
boot log of kernel with aperture alloc changed to __alloc_bootmem_low
Comment 8 Luis Claudio R. Goncalves 2008-12-16 10:32:13 EST

*** This bug has been marked as a duplicate of bug 466341 ***

Note You need to log in before you can comment on or make changes to this bug.