Bug 443930 - GoogleEarth crashes PC
GoogleEarth crashes PC
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
rawhide
i686 Linux
low Severity high
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-24 03:24 EDT by malcolm
Modified: 2008-05-21 10:38 EDT (History)
4 users (show)

See Also:
Fixed In Version: 7.1-0.31.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-13 11:26:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
window covering application with focus (378.62 KB, image/png)
2008-04-25 09:26 EDT, malcolm
no flags Details
crashlog-F0676D77.txt (4.19 KB, text/plain)
2008-04-30 09:18 EDT, Scott Clark
no flags Details

  None (edit)
Description malcolm 2008-04-24 03:24:30 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. run GoogleEarth
2. Click OK at Startup tips
3.
  
Actual results:

Machine crashes
Screen freezes, keyboard lights flash, must power off to end

Expected results:

Google Earth runs

Additional info:

GoogleEarth 4.3.7191.6508
Works fine on identical machine with Fedora 8
Makes no difference if wobbly windows on or off
Comment 1 malcolm 2008-04-24 03:34:48 EDT
Briefly saw a message that said 

Failed to initialize TTM buffer manager Falling back to classic

before machine fell over.
Comment 2 Dave Airlie 2008-04-24 05:01:42 EDT
can you re-try with the latest kernel from koji 2.6.25-8.fc9 at this point..
Comment 3 malcolm 2008-04-24 05:55:14 EDT
Nope, you've lost me there :-(

this is what I have:
Linux fedora9.whsg.info 2.6.25-1.fc9.i686 #1 SMP Thu Apr 17 01:47:10 EDT 2008
i686 i686 i386 GNU/Linux

who is koji and where do I find his/her latest 
and greatest kernel and more to the point how do I install it 

I think this is like bug 438017 

I have tried adding option "DRI2" "true" in the device line 
but the xserver won't start then ( it's an Intel on board thingy )

I'm more than happy to give it a go but I think I need an idiots guide 

Sorry

Comment 4 Dave Airlie 2008-04-24 08:47:43 EDT
http://koji.fedoraproject.org/packages/kernel/2.6.25/8.fc9/

grab the kernel rpm for you arch from there and install it with rpm -ivh <rpm>

and boot into and see if it still happens..

thanks.
Comment 5 malcolm 2008-04-24 09:36:48 EDT
OK, there is good news and bad news

Linux fedora9.whsg.info 2.6.25-8.fc9.i686 #1 SMP Wed Apr 23 03:56:19 EDT 2008
i686 i686 i386 GNU/Linux


I did the update and Googleearth will now start without killing the PC
but it runs really badly and looks like a negative black and white picture
I tried to look in the options to see if there was anything I could fiddle
with but then it stopped. Clicking in the x let me force quit an it left this

googleearth

Failed to initialize TTM buffer manager.  Falling back to classic.
Google Earth has caught signal 11.

Stacktrace from glibc:
  ./googleearth-bin [0x804f3c7]
  ./googleearth-bin [0x804f8ed]
  [0x110400]
  /lib/libc.so.6 [0xec0e1d]
  /lib/libc.so.6 [0xec224f]
  /lib/libc.so.6(realloc+0x106) [0xec3176]
  ./libQtCore.so.4(_Z8qReallocPvj+0x1e) [0x22b6c6]
  ./libQtCore.so.4(_ZN10QByteArray7reallocEi+0xcc) [0x2344cc]
  ./libQtCore.so.4(_ZN10QByteArray6resizeEi+0x46) [0x234a66]
  ./libge_net.so(_ZN5earth3net18CurlHttpConnection13curlWriteFuncEPvjjS2_+0x4c)
[0x8dfc7aa]
  ./libcurl.so.4(Curl_client_write+0xc1) [0x2bd2621]
  ./libcurl.so.4(Curl_readwrite+0x472) [0x2be2632]
  ./libcurl.so.4(Curl_perform+0x3ea) [0x2be44ca]
  ./libcurl.so.4(curl_easy_perform+0x56) [0x2be4a06]
 
./libge_net.so(_ZN5earth3net18CurlHttpConnection11sendRequestEPNS0_11HttpRequestE+0x6cc)
[0x8e10ee2]
  ./libge_net.so(_ZN5earth3net18CurlHttpConnection20processAsyncRequestsEv+0x4a)
[0x8e10702]
  ./libge_net.so(_ZN5earth3net18CurlHttpConnection10threadFuncEPv+0x1d) [0x8e1075b]
  /lib/libpthread.so.0 [0xfc032f]
  /lib/libc.so.6(clone+0x5e) [0xf2f26e]




We apologize for the inconvenience, but Google Earth has crashed.
 This is a bug in the program, and should never happen under normal
 circumstances. A bug report and debugging data are now being written
 to this text file:

    /home/malcolm/.googleearth/crashlogs/crashlog-CD55C1B3.txt

This bug report will be sent to Google automatically next time you run
 Google Earth. Its data, which contains no personal information, will help
 us correct problems without bothering you further. If you would rather
 this info not be transmitted, please delete the above file before running
 the program again. If you want bug reports to NEVER be sent, remove the
 above 'crashlogs' directory's read/write permissions.

Let me know if there is anything else you need - in the meantime I will
play and see what happens
Comment 6 Matěj Cepl 2008-04-25 07:03:16 EDT
Could we get that file as well, please, attached to this bug?
Comment 7 malcolm 2008-04-25 09:26:42 EDT
Created attachment 303780 [details]
window covering application with focus
Comment 8 malcolm 2008-04-25 09:34:02 EDT
there isn't a file in the location the text suggests and now I can't get it to
do it again. I have ( hopefully ) included a screenshot so you can see I'm not mad.
In the mean time I will try and get it to generate some meaningful self destruct
messages 
Comment 9 malcolm 2008-04-25 11:29:00 EDT
Incidentally, since this report has been running I have discovered that there is
a mention on freedesktop.org about TTM buffer manager - mesa/DRI/i915 and over
the last couple of days there has been a few moans popping up about compiz
exploding with Failed to initilize TTM buffer manager. So you might be trying to
reinvent the wheel here -as in - it might be the infamous 'some one elses problem'
Comment 10 malcolm 2008-04-28 06:03:38 EDT
Stuffed a GeForce 6500 NVidia card in the machine and although the performance
isn't exactly stellar with the nv driver it works fine. ( the Nvidia binary
wouldn't compile )
Comment 11 Scott Clark 2008-04-30 09:17:28 EDT
I believe I am getting the same or a very similar bug. In my case, Google Earth
starts and shows the info dialog. Then I click okay, and it goes away and the
earth starts to spin and looks correct, but the program then crashes
(dissapears). Here is the command-line output, and I will attach the file:

$ googleearth > googleearthoutput.log 2>&1
Failed to initialize TTM buffer manager.  Falling back to classic.
googleearth-bin: ../common/dri_bufmgr_fake.c:982: dri_fake_emit_reloc: Assertion
`target_fake->is_static || target_fake->size_accounted' failed.
Google Earth has caught signal 6.

Stacktrace from glibc:
  ./googleearth-bin [0x804f403]
  ./googleearth-bin [0x804f916]
  [0x110400]
  /lib/libc.so.6(abort+0x188) [0xe8a028]
  /lib/libc.so.6(__assert_fail+0xee) [0xe8157e]
  /usr/lib/dri/i965_dri.so [0x22a1066]
  /usr/lib/dri/i965_dri.so(dri_emit_reloc+0x1f) [0x229f9d1]
  /usr/lib/dri/i965_dri.so(intel_batchbuffer_emit_reloc+0x34) [0x22a132c]
  /usr/lib/dri/i965_dri.so(brw_emit_vertices+0xed) [0x22bbe46]
  /usr/lib/dri/i965_dri.so(brw_draw_prims+0x335) [0x22bb871]
  /usr/lib/dri/libdricore.so(vbo_rebase_prims+0x2a3) [0x45db7a7]
  /usr/lib/dri/i965_dri.so(brw_draw_prims+0x4d7) [0x22bba13]
  /usr/lib/dri/libdricore.so [0x45da5d7]
  /usr/lib/dri/libdricore.so [0x45da7c7]
 
/opt/google-earth/libIGGfx.so(_ZN3Gap3Gfx18igOglVisualContext11genericDrawEiiiii+0x29b)
[0x924694b]
 
/opt/google-earth/libIGGfx.so(_ZN3Gap3Gfx18igOglVisualContext12internalDrawENS0_11IG_GFX_DRAWEiiii+0xc8)
[0x92608a8]
 
/opt/google-earth/libIGGfx.so(_ZN3Gap3Gfx18igOglVisualContext11drawIndexedENS0_11IG_GFX_DRAWEiiii+0x30)
[0x92608e0]
 
/opt/google-earth/libevll.so(_ZN5earth4evll12DrawableData9flushGeomEPN3Gap3Gfx15igVisualContextEPS1_RPtRiS9_S9_+0xc5)
[0x15fc525]
 
/opt/google-earth/libevll.so(_ZN5earth4evll12DrawableData12drawGeomListERSt6vectorIPS1_SaIS3_EERKNS_5Vec3dEPN3Gap3Gfx15igVisualContextEbPKNS_11BoundingBoxIdS7_EEb+0x40f)
[0x15fc9af]
 
/opt/google-earth/libevll.so(_ZN5earth4evll12DrawableData13drawGeomListsEPN3Gap3Gfx15igVisualContextEi+0xe4)
[0x15fcd94]
 
/opt/google-earth/libevll.so(_ZN5earth4evll12DrawableData16drawDrawableListEPN3Gap3Gfx15igVisualContextE+0x1c0)
[0x15fcfa0]
  /opt/google-earth/libevll.so(_ZN5earth4evll8Database16DrawDrawablesAllEv+0x1f)
[0x15b739f]
  /opt/google-earth/libevll.so(_ZN5earth4evll13VisualContext6renderEb+0xabd)
[0x1534d9d]
  /opt/google-earth/libevll.so(_ZN5earth4evll13VisualContext4drawEbb+0x1c4)
[0x15376a4]
  /opt/google-earth/libevll.so(_ZN5earth4evll17RenderContextImpl4drawEv+0x166)
[0x16d3ec6]
  ./librender.so(_ZN12RenderWidget10paintEventEP11QPaintEvent+0x2a) [0x1264caa]
  ./librender.so(_ZN5earth6render11RenderTimer4fireEv+0x1a) [0x12721ca]
  ./libbase.so(_ZN5earth5Timer8dispatchEv+0x2d) [0x104e6cd]
 
./libgoogleearth_lib.so(_ZN5earth6client11Application18CommandCustomEvent8dispatchEv+0x23)
[0xdd23f3]
 
./libgoogleearth_lib.so(_ZN5earth6client11Application11customEventEP6QEvent+0x3a) [0xdc3dea]
  ./libQtCore.so.4(_ZN7QObject5eventEP6QEvent+0xed) [0x4289a1]
 
./libQtGui.so.4(_ZN19QApplicationPrivate13notify_helperEP7QObjectP6QEvent+0x1d3)
[0x60f44b]
  ./libQtGui.so.4(_ZN12QApplication6notifyEP7QObjectP6QEvent+0xb4) [0x615fc0]
  ./libQtCore.so.4(_ZN16QCoreApplication14notifyInternalEP7QObjectP6QEvent+0x62)
[0x41aeda]
 
./libQtCore.so.4(_ZN23QCoreApplicationPrivate16sendPostedEventsEP7QObjectiP11QThreadData+0x247)
[0x41c9db]
  ./libQtCore.so.4(_ZN16QCoreApplication16sendPostedEventsEP7QObjecti+0x23)
[0x41cc4f]
  ./libQtCore.so.4 [0x43aa9a]
  /lib/libglib-2.0.so.0(g_main_context_dispatch+0x1e8) [0x5a21098]
  /lib/libglib-2.0.so.0 [0x5a24743]
  /lib/libglib-2.0.so.0(g_main_context_iteration+0x71) [0x5a24901]
 
./libQtCore.so.4(_ZN20QEventDispatcherGlib13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE+0x53)
[0x43a61b]
  ./libQtGui.so.4 [0x67dc92]
 
./libQtCore.so.4(_ZN10QEventLoop13processEventsE6QFlagsINS_17ProcessEventsFlagEE+0x2d)
[0x41a861]
  ./libQtCore.so.4(_ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE+0xc7)
[0x41aa07]
  ./libQtCore.so.4(_ZN16QCoreApplication4execEv+0x98) [0x41ccf0]
  ./libQtGui.so.4(_ZN12QApplication4execEv+0x25) [0x60ef15]
  ./libgoogleearth_lib.so(_ZN5earth6client11Application3runEv+0x380) [0xdd04e0]
  ./googleearth-bin(main+0x2ba) [0x8050bea]
  /lib/libc.so.6(__libc_start_main+0xe6) [0xe745d6]
  ./googleearth-bin [0x804f231]




We apologize for the inconvenience, but Google Earth has crashed.
 This is a bug in the program, and should never happen under normal
 circumstances. A bug report and debugging data are now being written
 to this text file:

    /home/scott/.googleearth/crashlogs/crashlog-F0676D77.txt

This bug report will be sent to Google automatically next time you run
 Google Earth. Its data, which contains no personal information, will help
 us correct problems without bothering you further. If you would rather
 this info not be transmitted, please delete the above file before running
 the program again. If you want bug reports to NEVER be sent, remove the
 above 'crashlogs' directory's read/write permissions.
Comment 12 Scott Clark 2008-04-30 09:18:28 EDT
Created attachment 304222 [details]
crashlog-F0676D77.txt
Comment 13 Scott Clark 2008-04-30 09:21:40 EDT
Hi,
It might also be useful to know that I have an Intel 965 chipset, and my smolt
profile is here:
http://www.smolts.org/client/show/pub_f3101190-7a18-47f0-aa25-a8529e50ce2b
Let me know if you need more info!
Comment 14 Dave Airlie 2008-05-06 20:46:43 EDT
should be fixed in the mesa-7.1-0.30.fc9 package which will be most likely a
0-day F9 update.
Comment 15 Fedora Update System 2008-05-11 20:17:51 EDT
mesa-7.1-0.31.fc9 has been submitted as an update for Fedora 9
Comment 16 Fedora Update System 2008-05-13 11:26:32 EDT
mesa-7.1-0.31.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Nils Philippsen 2008-05-14 15:59:54 EDT
*** Bug 442818 has been marked as a duplicate of this bug. ***
Comment 18 vvs 2008-05-21 03:52:57 EDT
For some reason there is still no mesa-7.1-0.31.fc9 in the updates repository.
And even worse - there never was one single mesa rpm, but four of them instead
(e.g. mesa-libGL{,U}{,-devel}). Whats up?
Comment 19 Scott Clark 2008-05-21 10:38:16 EDT
When Fedora 9 final was released, I did not get the updates until I ran "yum
clean all" from the command line. I'm not sure exactly why this solved things,
but I'm guessing the URLs of the update sites changed and yum had them cached
incorrectly. Anyway I have no idea if this is your problem, but you might want
to check this out in the yum manpage and give it a shot, then try updating
again. Also you might get a better response at fedoraforum.org for these types
of question, so check that out. Hope that helps.

Note You need to log in before you can comment on or make changes to this bug.