Bug 443957 - boinc-client daemon do not start after Boinc instalation immediately
boinc-client daemon do not start after Boinc instalation immediately
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: boinc-client (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Milos Jakubicek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-24 07:59 EDT by Anton Krajcik
Modified: 2008-04-24 10:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-24 10:37:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anton Krajcik 2008-04-24 07:59:20 EDT
Description of problem:
Problem #1
boinc-client daemon do not start after Boinc instalation immediately

Problem #2
'root' access is required to setup Boinc Manager

Problem #3
'root' access is required to setup Boinc Manager after reboot of PC



Version-Release number of selected component (if applicable):
boinc-client-5.10.45-9.20080315svn.fc8.i386.rpm
boinc-client-debuginfo-5.10.45-9.20080315svn.fc8.i386.rpm
boinc-client-devel-5.10.45-9.20080315svn.fc8.i386.rpm
boinc-manager-5.10.45-9.20080315svn.fc8.i386.rpm

Explanation:
After instalation via 'yum install boinc-client boinc-manager' I am not able to 
start Boinc Manager correctly because 'boinc-client daemon' is not running 
immediately past instalation.
I must start 'boinc-client daemon'as root through '/sbin/chkconfig boinc-client 
on' and reboot my PC.
'/sbin/chkconfig boinc-client start' - does not work

Atter reboot I must 'Select computer' with these parameters (in Boinc Manager - 
Advanced Mode)
host name: localhost
password: content of file gui_rpc_auth.cfg (as root I must in Terminal execute 
this command 'gedit /var/lib/boinc/gui_rpc_auth.cfg')

The same results I obtained after installation .rpm packages showed above in 
'Version-Release number of selected component (if applicable)'


Another problem is that after every reboot of PC I am again forced to insert 
'localhost' and password (content of file gui_rpc_auth.cfg) as root.
Comment 1 Milos Jakubicek 2008-04-24 10:37:28 EDT
(In reply to comment #0)
> Description of problem:
> Problem #1
> boinc-client daemon do not start after Boinc instalation immediately

Correct.
See the following part of Fedora packaging gudelines for initscripts for details:
http://fedoraproject.org/wiki/Packaging/SysVInitScript#head-c074b6a78b42c4c797d978750719ebcf262b4e61http://fedoraproject.org/wiki/Packaging/SysVInitScript#head-c074b6a78b42c4c797d978750719ebcf262b4e61
 
> Problem #2
> 'root' access is required to setup Boinc Manager
> 
> Problem #3
> 'root' access is required to setup Boinc Manager after reboot of PC

Both correct -- this is the desired behavior.

> '/sbin/chkconfig boinc-client start' - does not work

And it never will, see "man chkconfig" for details. Probably you wanted to run
"service boinc-client start".
 
> Atter reboot I must 'Select computer' with these parameters (in Boinc Manager - 
> Advanced Mode)
> host name: localhost
> password: content of file gui_rpc_auth.cfg (as root I must in Terminal execute 
> this command 'gedit /var/lib/boinc/gui_rpc_auth.cfg')
> 
> The same results I obtained after installation .rpm packages showed above in 
> 'Version-Release number of selected component (if applicable)'
> 
> 
> Another problem is that after every reboot of PC I am again forced to insert 
> 'localhost' and password (content of file gui_rpc_auth.cfg) as root.

None of the things you listed above is a bug => closing as NOTABUG.
Comment 2 Milos Jakubicek 2008-04-24 10:44:36 EDT
...and to anticipate next question, if you do not want to have to enter your
password every time, just edit the gui_rpc_auth.cfg and insert _only_ a newline.

Note You need to log in before you can comment on or make changes to this bug.