This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 443982 - Qemu SELinux messages
Qemu SELinux messages
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: David Woodhouse
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-24 10:10 EDT by Martin Jürgens
Modified: 2009-04-20 08:42 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-20 05:57:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
selinux alerts i encounter (5.17 KB, text/plain)
2008-04-24 10:10 EDT, Martin Jürgens
no flags Details

  None (edit)
Description Martin Jürgens 2008-04-24 10:10:50 EDT
Description of problem:
I'm using virt-manager to start create Qemu machines. When I finish to create
them / start them i get lots of Selinux messages. I already tried to relabel the
files stated there, but it does not fix the issues.

Version-Release number of selected component (if applicable):
qemu-0.9.1-5.fc9.i386

How reproducible:
Always

Steps to Reproduce:
1. Create qemu virtual machine using virt-manager
2.
3.
  
Actual results:
SELinux errors
Comment 1 Martin Jürgens 2008-04-24 10:10:50 EDT
Created attachment 303633 [details]
selinux alerts i encounter
Comment 2 John Poelstra 2008-04-24 18:17:58 EDT
David-is this really a qemu issue or should this be reassigned to
selinux-targeted-policy?
Comment 3 Bug Zapper 2008-05-14 06:04:53 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Brennan Ashton 2008-06-07 23:05:32 EDT
Assignee, could you please reply to the previous question? If you won't reply in
one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.
Comment 5 Daniel Berrange 2008-06-11 06:05:58 EDT
Where did you locate your disk images ?  

As of Fedora 9, if you are running with SELinux enabled & enforcing, disk images
need to be located under /var/lib/libvirt/images/

Comment 6 William Lovaton 2008-12-27 16:41:33 EST
(In reply to comment #5)
> Where did you locate your disk images ?  
> 
> As of Fedora 9, if you are running with SELinux enabled & enforcing, disk images
> need to be located under /var/lib/libvirt/images/

I think this might be the problem.  I tried installing WinXP from the CD under qemu-kvm and it worked fine.  Then I repeated the installation copying the iso to my home directory and virt-manager failed starting the virtual machine because SELinux forbids access to the iso image.  I tried changing the context of the iso image as suggested by the troubleshooter but it didn't work.  I had to change SELinux to permissive mode temporarily while doing the installation.
Comment 7 Mark McLoughlin 2009-04-20 05:57:24 EDT
Missing info from reporter, closing
Comment 8 William Lovaton 2009-04-20 08:42:58 EDT
Mmmm, I promise I'll try this on my updated Fedora 10 laptop and post a comment here.

But, why images need to be located in /var/lib/libvirt/images/? can't a mortal user use his home directory? I think Qemu/KVM should work without root privileges.

Note You need to log in before you can comment on or make changes to this bug.