Bug 443984 - SOSreport does not gather SELinux audit logs
SOSreport does not gather SELinux audit logs
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: sos (Show other bugs)
5.5
All Linux
low Severity low
: rc
: ---
Assigned To: Adam Stokes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-24 10:17 EDT by Paul Dwyer
Modified: 2012-04-23 08:31 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-30 04:07:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Dwyer 2008-04-24 10:17:32 EDT
Description of problem:
SOSreport does not gather SELinux audit log files (/var/log/audit/*)

These would be very useful when troubleshooting a problem potentially caused by
an SELinux denial.

Version-Release number of selected component (if applicable):
sos-1.7-9.2.el5 tested

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Marco Grigull 2008-04-30 19:56:30 EDT
This should be collected regardless of the current assumed state of selinux.  
  

Notwithstanding, in rare cases syslogd can be prevented from creating *any* logs
and is caused by incorrect file SE labels in /var....

Comment 3 Marco Grigull 2008-04-30 21:51:07 EDT
The last 50 entries would provide enough information for 90% of the cases (based
on guestimate), it should not be necessary to capture all of the events.  If
there are many un-addressed events then we can request all of the
/var/log/audit/ logs manually.

As /etc/selinux /slash/ /etc/sysconfig/selinux provide false information, having
a part of the audit information available also helps to determine whether
selinux is having an impact on operations.
Comment 4 RHEL Product and Program Management 2008-06-02 16:04:19 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 5 RHEL Product and Program Management 2008-10-27 14:21:01 EDT
This request was previously evaluated by Red Hat Product Management
for inclusion in the current Red Hat Enterprise Linux release, but
Red Hat was unable to resolve it in time.  This request will be
reviewed for a future Red Hat Enterprise Linux release.
Comment 10 errata-xmlrpc 2010-03-30 04:07:38 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0201.html

Note You need to log in before you can comment on or make changes to this bug.