Bug 443986 - Lots of mislabeled files on 4.7 installs
Lots of mislabeled files on 4.7 installs
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: selinux-policy-targeted (Show other bugs)
4.7
All Linux
low Severity low
: rc
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks: RHEL4u7_relnotes
  Show dependency treegraph
 
Reported: 2008-04-24 10:22 EDT by Alexander Todorov
Modified: 2008-08-11 22:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-25 13:37:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2008-04-24 10:22:35 EDT
Description of problem:
RTT automated test cases have discovered lots of mislabeled files on latest
RHEL4.7 installs. The file context is compared to the values in 
/etc/selinux/targeted/contexts/files/file_contexts


Version-Release number of selected component (if applicable):
selinux-policy-targeted-1.17.30-2.149

How reproducible:
Always

Steps to Reproduce:
1. Install the OS
2.
3.
  
Actual results:
Lots of mislabeled files

Expected results:
Few mislabeled files (due to being CDROM instead of hard drive or the intended
context was not appropriate)

Additional info:
Some of the problems come from %post scriptlets that are mislabeling files when
package is installed.
We're opening this bug to track a release note as the list of files is not small
and they'll have to be evaluated on one-by-one basis (most probably).
Comment 3 RHEL Product and Program Management 2008-04-24 10:30:26 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 5 RHEL Product and Program Management 2008-04-25 13:37:54 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request. 
Comment 7 Don Domingo 2008-06-02 19:15:17 EDT
Hi,

the RHEL4.7 release notes deadline is on June 17, 2008 (Tuesday). they will
undergo a final proofread before being dropped to translation, at which point no
further additions or revisions will be entertained.

a mockup of the RHEL4.7 release notes can be viewed here:
http://intranet.corp.redhat.com/ic/intranet/RHEL4u7relnotesmockup.html

please use the aforementioned link to verify if your bugzilla is already in the
release notes (if it needs to be). each item in the release notes contains a
link to its original bug; as such, you can search through the release notes by
bug number.

Cheers,
Don

Note You need to log in before you can comment on or make changes to this bug.