Bug 443991 - RFE: PKCS#11/smartcard support
RFE: PKCS#11/smartcard support
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subversion (Show other bugs)
5.3
All Linux
high Severity high
: rc
: ---
Assigned To: Joe Orton
:
Depends On: 443127 443994
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-24 10:37 EDT by Joe Orton
Modified: 2009-09-03 10:20 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:54:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Orton 2008-04-24 10:37:14 EDT
Description of problem:
Subversion 1.4 lacks support for use of PKCS#11 providers for pulling SSL client
certs from smart cards.  This support has been added upstream for 1.5.x and
could be backported.

Version-Release number of selected component (if applicable):
subversion-1.4.2-2.el5
Comment 1 Joe Orton 2008-04-24 10:39:25 EDT
The CoolKey PKCS#11 C_Initialize fix is needed alongside this.
Comment 3 RHEL Product and Program Management 2008-06-02 16:04:16 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 6 Alparslan Ozturk 2008-08-15 15:07:00 EDT
Hi,

I'm using Siemes CardOS 4.3b version smartcard with pkcs#11 library of opensc and with "pcsc" deamon for smartkart logon process. Additionally work with Firefox, thunderbird and nss tools. But I can't configure the coolkey and  ESC desktop smart card manager.

I was tried pkcs#11 library of coolkey but. The library doesn't access my smartcard. 

I want to support simens cardOS 4.3B.

thanks,
best regards.
Comment 10 errata-xmlrpc 2009-01-20 16:54:34 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-0194.html

Note You need to log in before you can comment on or make changes to this bug.