Bug 444001 - Annoying startup and rc1, rcS, rcS-sulogin message glitches, man page typos.
Annoying startup and rc1, rcS, rcS-sulogin message glitches, man page typos.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: event-compat-sysv (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Casey Dahlin
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-24 10:58 EDT by archimerged Ark submedes
Modified: 2014-06-18 04:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-19 14:27:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch which fixes those annoyances. (6.00 KB, patch)
2008-04-24 11:03 EDT, archimerged Ark submedes
no flags Details | Diff
revised patch to rcS-sulogin to fix a different bug. (861 bytes, patch)
2008-04-24 12:07 EDT, archimerged Ark submedes
no flags Details | Diff
patch for this issue (2.03 KB, patch)
2008-04-24 15:43 EDT, Bill Nottingham
no flags Details | Diff

  None (edit)
Description archimerged Ark submedes 2008-04-24 10:58:28 EDT
Description of problem:

Annoying startup and rc1, rcS, rcS-sulogin message glitches, man page typos.

Version-Release number of selected component (if applicable):
event-compat-sysv-0.3.9-13.fc9.noarch
initscripts-8.70-1.i386
NetworkManager-0.7.0-0.9.2.svn3566.fc9.i386
upstart-0.3.9-17.fc9.i386

How reproducible: very

Steps to Reproduce:
1. boot to single user mode & exit see rcS killed message
2. boot normally see some [OK] on the second line, and rcS killed message
3. telinit 1 and see rc1 and rcS-sulogin killed messages
4. read events(5) and initctl(8) man pages see typos.

Actual results:
user gets annoyed and anxious

Expected results:
startup messages shouldn't look like errors

Additional info:

Files patched:

/usr/share/man/man5/events.5.gz
/usr/share/man/man8/initctl.8.gz
/etc/rc.d/init.d/NetworkManager
/etc/event.d/rc1
/etc/event.d/rcS
/etc/event.d/rcS-sulogin
/etc/rc.d/rc.sysinit
/etc/rc.d/init.d/single

They belong to packages:

event-compat-sysv-0.3.9-13.fc9.noarch
initscripts-8.70-1.i386
NetworkManager-0.7.0-0.9.2.svn3566.fc9.i386
upstart-0.3.9-17.fc9.i386

Patch will be attached.
Bug will be cloned and attached to those four components.
Comment 1 archimerged Ark submedes 2008-04-24 11:03:46 EDT
Created attachment 303642 [details]
Patch which fixes those annoyances.

The change to /etc/rc.d/init.d/single makes it completely dispensable.
All it does is clear the screen.  /etc/event.d/rc1 now does the telinit S.
But you wouldn't want this version of init.d/single installed without the
matching event.d/rc1.
Comment 2 Bill Nottingham 2008-04-24 11:24:58 EDT
I'd rather just nuke S99single for the upstart case. (And also move
event-compat-sysv into initscripts, as it would make things like this a lot
simpler.)
Comment 3 archimerged Ark submedes 2008-04-24 12:07:04 EDT
Created attachment 303655 [details]
revised patch to rcS-sulogin to fix a different bug.

Noticed another bug:  if the last command you execute in bash
has a nonzero exit code, and you exit by typing "exit" rather than "exit 0",
you can't do anything except CTL-ALT-DELETE to reboot.
Comment 4 Bill Nottingham 2008-04-24 12:54:10 EDT
I'm not seeing why you need a kill timeout/trap in rc1.
Comment 5 Bill Nottingham 2008-04-24 12:57:26 EDT
In fact, unless I'm missing something, all the 'kill timeout/trap' can be elided
by simply doing 'exec telinit ...'
Comment 6 Bill Nottingham 2008-04-24 14:53:31 EDT
Hm, that just appears to shorten the race. That being said, the kill/trap just
seems wrong as a way to avoid the message.
Comment 7 Bill Nottingham 2008-04-24 15:01:19 EDT
Moving the telinit machinations to post-stop should do the trick. Will generate
a new patchset momentarily.
Comment 8 Bill Nottingham 2008-04-24 15:43:39 EDT
Created attachment 303679 [details]
patch for this issue

Here's an incremental version of what I'm committing.
Comment 9 Bill Nottingham 2008-04-24 15:44:20 EDT
Will be in 0.3.9-14.fc9 and initscripts-8.72-1.
Comment 10 archimerged Ark submedes 2008-04-24 23:54:10 EDT
s/echo "Telling INIT/echo $"Telling INIT/  since it is a translated string.

rcS-sulogin post stop should only do telinit if runlevel is still S.

Otherwise, user must have already asked for a different runlevel and
he won't like being overruled.

-------

man event(5) says:

       post-stop
              Execute the command/script after stopping the process.
              The format is similar to pre-start.

That seems to imply that the command/script only runs if upstart
stopped the process, not if the process exited.

s/stopping the process/the process has exited./

Hmm, looking at the SRPM, I see events.5 is very new and I am speaking to the
author... so I guess I don't need to attach this comment to the upstart package
bug...
Comment 11 archimerged Ark submedes 2008-04-25 00:48:26 EDT
s:/bin/bash || true:exec /bin/bash:

Cleaner:  /bin/bash is the rcS-sulogin main process.
Presumably upstart will report nonzero exit code.
Comment 12 Bill Nottingham 2008-04-25 13:16:33 EDT
I'm not sure we *care* about the exit code of bash, though. In any case, will do
some poking along the lines of comment #10.
Comment 14 Bug Zapper 2008-05-14 06:05:06 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 15 Casey Dahlin 2008-08-04 16:41:33 EDT
This seems to all be sorted. Can we close this?
Comment 16 Casey Dahlin 2008-10-19 14:27:44 EDT
Closing this, since nobody protested.

Note You need to log in before you can comment on or make changes to this bug.