Bug 444010 - we still ship /etc/inittab
we still ship /etc/inittab
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rhgb (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Blocker
  Show dependency treegraph
 
Reported: 2008-04-24 11:18 EDT by Chris Lumens
Modified: 2008-05-02 13:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-29 16:17:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Chris Lumens 2008-04-24 11:18:16 EDT
The following commit is trouble:

* Tue Mar 18 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 1:0.17.7-11
- Don't check /etc/inittab for default runlevel since it may no longer be
  present

We still ship a /etc/inittab, and this is what anaconda is writing out for now.
 What's happening is that after a text install, we have runlevel 3 in the
inittab and GRAPHICAL=yes in the /etc/sysconfig/init file.  upstart starts up in
runlevel 3 as indicated by /sbin/runlevel, but rhgb runs anyway.

The end result is that text mode firstboot starts up in the rhgb expanded
window.  That quickly dies and leaves us with a wonderful expanse of blue on the
screen and nothing else.
Comment 1 Bill Nottingham 2008-04-24 14:42:06 EDT
Fixed in 9.0.0-3.
Comment 2 Bill Nottingham 2008-04-29 16:17:21 EDT
And verified.

Note You need to log in before you can comment on or make changes to this bug.